1

I just updated my kernel in Fedora as it asked me in a routine pop-up.

After the update, this is what I have:

[root@redberret ~]# dnf info kernel-headers
Last metadata expiration check: 0:19:44 ago on Sun 28 Jan 2018 10:42:11 AM EST.
Installed Packages
Name         : kernel-headers
Version      : 4.14.14
Release      : 300.fc27
Arch         : x86_64
Size         : 4.3 M
Source       : kernel-4.14.14-300.fc27.src.rpm
Repo         : @System
From repo    : updates
Summary      : Header files for the Linux kernel for use by glibc
URL          : http://www.kernel.org/
License      : GPLv2 and Redistributable, no modification permitted
Description  : Kernel-headers includes the C header files that specify the interface
             : between the Linux kernel and userspace libraries and programs.  The
             : header files define structures and constants that are needed for
             : building most standard programs and are also needed for rebuilding the
             : glibc package.

[root@redberret ~]# uname -r
4.13.9-300.fc27.x86_64

My system thinks I have version 4.13.9, while dnf thinks I have 4.14.14 installed.

I tried manually installing 4.14.14 via

[root@redberret ~]# dnf install kernel-4.14.14-300.fc27.x86_64
Last metadata expiration check: 0:26:20 ago on Sun 28 Jan 2018 10:42:11 AM EST.
Package kernel-4.14.14-300.fc27.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

And I'm still shown 4.13.9 in $(uname -r).

In my GRUB screen, I see two options to boot from: the kernel version 4.13.9, or the rescue drive.

I googled around, and some threads suggested it was because of an old OS installation. It might be the case since I had upgraded this from Fedora 26 to Fedora 27, and that upgrade gave me some troubles.

I don't know if there is something wrong with my disk partitions. Here is a screen shot of what it looks like:

partition information

Help would be really appreciated.

  • Try to run grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg to generate a new grub config. It should pick up any valid kernels and initial ramdisks in /boot. If that also fails, try to dnf reinstall kernel-4.14.14-300.fc27.x86_64 which should reinstall the package and execute all the post-install scripts. – Thomas Jan 28 '18 at 16:38
  • @Thomas I tried both of your suggestions. Rebooted after each tine. Strangely enough, I'm still getting 4.13.9 with uname -r – mhz Jan 30 '18 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.