2

I have a Bluetooth headset that I usually use for listening to music on my laptop, and they tend to work fine. Unless I try to use the pulseaudio equalizer, and then it switches the output to my laptop speakers any time there's a pause/break/any dead space in audio output, until I disable and reenable the equalizer again.

I've gone as far as I can figure out by myself, and I've found out that when starting up, the equalizer changes the default sink from the ALSA sink (which is defaulted to a bluez sink for my headset) to the LADSPA sink, which according to somewhere (either the ArchWiki or StackExchange) is necessary to be able to apply effects and whatnot.

So! Is there some way to prevent the equalizer from doing this?


Setup: Lenovo Thinkpad running Fedora 27 with KDE, uname -r output: 4.14.13-300.fc27.x86_64

Output from running pulseaudio-equalizer enable:

-------------------------------------
Current operation: enabling equalizer
-------------------------------------
Unloading & reloading stream-restore module...
Loading module-ladspa-sink...
Transferring current mute (0) & volume (25%) to LADSPA sink (ladspa_output.mbeq_1197.mbeq)...
Setting ALSA sink (bluez_sink.[bluetooth address].a2dp_sink) preamp (1.0x)...
Setting LADSPA sink (ladspa_output.mbeq_1197.mbeq) as default sink...
Moving active PulseAudio clients to LADSPA sink (ladspa_output.mbeq_1197.mbeq)...
-------------------------------------
Equalizer status: [enabled]
Equalizer configuration status: [disabled]
Equalizer plugin: [mbeq_1197/mbeq]
Equalizer control: [0,0,0,0,0,0,0,0,0,0,0,0,0,0,0]
NOTE: Using user-customized settings from '/home/[username]/.pulse/equalizerrc'...
-------------------------------------
0

I'm one year late, but:

Is your pulseaudio config really putting your bluetooth sink as the fallback output?

I've come accross this same problem and I found out that the ladspa module, when loaded, must specify the master output.

Then I inspected the code of pulseaudio-equalizer binary and found out it reads the lists of sinks and sets the fallback sink as the output.

All you have to do (at least in my version) is set the bluetooth output as fallback and then start the equalizer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.