-3

I have trouble executing binary file, both from the GUI and the command line. I am running Ubuntu 17.10 . Here are the logs :

julien@julien-PC:~/JEUX/ROMS/Logiciels/snes9x-1.53$ ls
data  docs  snes9x-gtk
julien@julien-PC:~/JEUX/ROMS/Logiciels/snes9x-1.53$ ./snes9x-gtk 
bash: ./snes9x-gtk: Aucun fichier ou dossier de ce type

PS : The last line is in French but it means "no file or directory of this type" .

I also have this issue with the Super Meat Boy installer I have downloaded from Humble Bundle.

UPDATE : Using file, I have :

julien@julien-PC:~/JEUX/ROMS/Logiciels/snes9x-1.53$ file ./snes9x-gtk 
./snes9x-gtk: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.9, not stripped

I tried the command /lib/ld-linux.so.2 ./snes9x-gtk (because it is the interpreter) and it was not found. After some research on Internet, I found it in the package lib32z1, and after installing it, when I retried the command, I get error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory.
By using the command ldd I have as output :

julien@julien-PC:~/JEUX/ROMS/Logiciels/snes9x-1.53$ ldd ./snes9x-gtk 
    linux-gate.so.1 =>  (0xf7f82000)
    libX11.so.6 => not found
    libdl.so.2 => /lib32/libdl.so.2 (0xf7f5b000)
    libXext.so.6 => not found
    libGL.so.1 => not found
    [...]
    libm.so.6 => /lib32/libm.so.6 (0xf7e54000)
    libgcc_s.so.1 => not found
    libc.so.6 => /lib32/libc.so.6 (0xf7c81000)
    /lib/ld-linux.so.2 (0xf7f84000)

There is a lot of missing dependencies...
I tried to fix both libX11 and libXext, but I had issues :
I assumed libX11 was in package libx11-6 but after trying to install it, it says that it is already installed. Same for libXext and package libxext-6.

Do you have any suggestions ? Thanks.

closed as unclear what you're asking by Rui F Ribeiro, GAD3R, Michael Homer, elbarna, DarkHeart Jan 28 '18 at 1:22

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • The file is 32 bits, and chances are your system is 64 bit. You then need to install the 32-bit version of those libraries: apt-get install libx11-6:i386; see ubuntuforums.org/showthread.php?t=2199929 (or is there a 64 bit version of the program you're trying to install?) – LSerni Jan 27 '18 at 21:25
2

These are 32-bit binaries; to get them running on your Ubuntu system, you need to install :i386 packages. The i386 architecture should already be enabled, but just in case, run

sudo dpkg --add-architecture i386
sudo apt update

Then install the missing libraries, e.g.

sudo apt install libx11-6:i386 zlib1g:i386

etc. To find packages containing the libraries you need, install apt-file:

sudo apt install apt-file
sudo apt-file update
apt-file search libX11.so.6
2

First of all determine what the file is:

file ./snes9x-gtk

and ensure it is of the correct type for your system. For example if you have a 32-bit system, of course this won't run:

ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked...

If the type is correct, try investigating with ldd. These are some errors I was able to make pop up:

$ ldd /usr/local/bin/tesseract
/usr/local/bin/tesseract: /usr/lib64/libstdc++.so.6: 
    version `GLIBCXX_3.4.11' not found 
    (required by /usr/local/lib/libtesseract_viewer.so.3)

$ ldd /usr/local/bin/qemu-system-x86_64
    ...
    libSDL-1.2.so.0 => not found
    ...

In this case you need to install the missing libraries (such as SDL in this example) or get an updated version of the program. Or recompile it on your system from the sources.

UPDATE: you seem to be trying to execute a SNES ROM? You can't do that on a non-SuperNintendo system. You need an emulator that will grok that ROM's format. Possibly, give a look here.

  • Thanks ! It is not the ROM that I try to execute but the installer of snes9x (which is an emulator). I have updated my question with file and ldd outputs. – Julien Vernay Jan 27 '18 at 20:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.