1

I am trying to install pyqt5 on linux;

$ cat /proc/version 
Linux version 4.11.4-1.el7.elrepo.x86_64 (mockbuild@Build64R7) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Wed Jun 7 12:18:44 EDT 2017

I got by the python3 and pip3 installation (with lots of difficulties), and when I finally got to do: sudo pip3 install pyqt5, I get:

Collecting pyqt5
  Using cached PyQt5-5.8-5.8.0-cp34.cp35.cp36.cp37-abi3-manylinux1_x86_64.whl
Collecting sip>=4.19.1 (from pyqt5)
  Could not find a version that satisfies the requirement sip>=4.19.1 (from pyqt5) (from versions: )
No matching distribution found for sip>=4.19.1 (from pyqt5)

I understand that sip 4.19.1 is a dependency (why can't pip3 install it automatically?), so I tried installing it with sudo yum install sip, hoping to get the latest sip, but instead I got:

Package sip-4.14.6-4.el7.x86_64 already installed and latest version

but 4.14.6 is not the latest, and doing sudo yum update sip did not help:

No packages marked for update

I found the latest installation of sip online: http://pyqt.sourceforge.net/Docs/sip4/installation.html But I'd rather installing it through command line by simply issuing sudo yum install $WHATEVER (because later I want to have the entire pyqt5 installation packed into a simple script).
What should I update in order for yum to find and install the latest sip (4.19.7)?

EDIT
Per @Norrius request in the comments, this is what I get:

$ sudo pip3 install SIP
Collecting SIP
  Could not find a version that satisfies the requirement SIP (from versions: )
No matching distribution found for SIP
$ python3 --version
Python 3.4.5
2
  • Can you please try pip3 install SIP and post your python3 --version if that fails?
    – Norrius
    Jan 27 '18 at 17:57
  • updated the post Jan 27 '18 at 18:48
3

It seems to be impossible to install PyQt5 on Python 3.4 through pip. Simply not supported. Your options are:

  • Skip PyQt's dependencies by pip3 install pyqt5 --no-deps and see if it works as is. You apparently have SIP on your system, but pip won't know anything about it since it's installed through yum. However, I don't know if PyQt5 will work with SIP 4.14.6. Try importing something, e.g. python3 -c "from PyQt5.QtWidgets import QApplication": if Python doesn't throw No module named 'sip', it probably works.
  • Download SIP 4.19 manually, build and install it and then install PyQt5 as per above. Although it's less convenient than getting everything from package managers, you still can pack this step into a simple script.
  • Go a step back and get newer Python. Currently the latest version is 3.6.4, but you should be able to pip3 install PyQt5 on Python 3.5 as well.

Related questions:

5
  • Thanks for help. I don't mind using python > 3.5. How do I upgrade my python 3 from command line? Once again, I'd rather do it from command line, but doing sudo yum install python3 came up with No package python3 available... Jan 27 '18 at 20:17
  • @so.very.tired Sorry, I have very limited experience in the Red Hat world. Assuming you're running RHEL 7, you should be able to add the EPEL repositories and install python36 from there. You might have to invoke pip as python36 -m pip though.
    – Norrius
    Jan 27 '18 at 20:33
  • Ok, I did. It is called python36.x86_64 in epel repo, but when I do yum install python36.x86_64 the installation fails on dependency which I could not find anywhere: Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit). Can you please help me install this dependency? Thanks! Feb 2 '18 at 8:43
  • @so.very.tired RPM has namespaced packages which I don't fully understand, but I'm guessing you need a different OpenSSL version. See this for example.
    – Norrius
    Feb 3 '18 at 8:28
  • Deserves all the 10 points it hasn't been assigned! Sep 3 '18 at 16:08
0

I solved my problem by installing the lxml, and I did not run this command: sudo pip3 install -r requirements/requirements-linux-python3.txt

All steps:

  1. pip3 install lxml
  2. make qt5py3
  3. python3 labelImg.py

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.