0

I have been using firewalld without any problems for about a year now. Recently I added a new zone docker, to which I added the virual docker0 interface, and added services to that zone, and that zone worked nicely without any problems as well. However, suddenly firewalld can no longer find my normal interface (wlp59s0). I believe I might have added wlp59s0 to docker as well. So I run

firewall-cmd --zone=work --change-interface=wlp59s0

firewall-cmd --reload

Which results in the following error message:

Error: 'FirewallZoneIPTables' object has no attribute '_FirewallZone__icmp_block_inversion'

If I run

systemctl status firewalld

the system spits out the following:

firewalld[6040]: ERROR: Failed to apply rules. A firewall reload might solve the issue if the firewall has been modified

firewalld[6040]: ERROR: set_rule() missing 1 required positional argument: 'log_denied'

I get no internet connection whatsoever when firewalld is on. I have absolutely no idea what to do here, I cannot find any resources online about this either. Can anyone please help me?

Update: I rolled back from 0.5.0-1 to 0.4.4.5-1 and the problem no longer persists.

migrated from serverfault.com Jan 26 '18 at 20:47

This question came from our site for system and network administrators.

0

Same problem here on Archlinux. I didn't change any settings in a year. Just updated and restart and firewalld refused to start with Error: 'FirewallZoneIPTables' object has no attribute '_FirewallZone__icmp_block_inversion' Downgraded to 0.4.4.6-1 and it works.

EDIT: Updated to 0.5.1-1 today and it's working now.

  • That's very interesting, because I run Arch as well, so it might be an Arch/firewalld problem. – Akitirija Jan 31 '18 at 10:20
  • Probably. I don't dare to update meanwhile because it's a production environment. Hope it'll be fixed soon. – R.J Feb 1 '18 at 13:32
  • Updated to latest version today and it's back to normal. – R.J Feb 6 '18 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.