1

Mageia release 6 (Official) for x86_64

4.14.13-desktop-1.mga

It's a mature install, not sure exactly how old, but this issue has existed since it was first installed.

What's happening is that I am experiencing about a 2 minute delay when booting the machine. I'm watching standard out and seeing that network drives are showing mounted, but they aren't. Then I see a job start running to mount drives:

screen cap from boot

The timeout on that job is 1:56 - almost 2 minutes. You can see that the job is 53 seconds in at the point that image was captured. The job simply times out and the drives have to be mounted manually (sudo mount -a).

My fstab has all of these drives configured like this:

adamsmdk:/backup-1 /mnt/adamsmdk/backup-1 nfs nosuid,rsize=8192,wsize=8192,_netdev 0 0

server:share mount-point nfs nosuid,rsize=8192,wsize=8192,_netdev 0 0

This shows up like this under the "mount" command:

adamsmdk:/backup-1 on /mnt/adamsmdk/backup-1 type nfs4 (rw,nosuid,relatime,vers=4.2,rsize=8192,wsize=8192,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.106,local_lock=none,addr=192.168.1.100,_netdev)

The "_netdev" option doesn't really seem to have any effect on the process, but it doesn't hurt anything either.

The shares are all on nfs servers and conform to this configuration in /etc/exports:

# generated by drakhosts.pl /backup-1 *(no_all_squash,async,secure,no_subtree_check,rw)

Systemd-analyze blame can be found at this link

systemd-analyze blame pastbin excerpt

Once boot completes, the shares can be mounted by root with "mount -a" and everything works just fine, but how do I resolve the trouble the system is having on boot? I'm starting to think I need to just go with automount, which works well on my laptops, but this is a desktop that should work better than it does.

Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.