0

I am trying to install LM 816 driver on my ARM v7 Ubuntu 14.04 machine. I downloaded the drivers from the official website of LM. Then I extracted them and I tried to install them with the install.sh file, but the result is not successful, this is the response I got:

Realtek Wi-Fi driver Auto installation script Novembor, 21 2011 v1.1.0

#

Decompress the driver source tar ball: rtl8188EUS_linux_v4.3.24_16705.20160509.tar.gz rtl8188EUS_linux_v4.3.24_16705.20160509/ rtl8188EUS_linux_v4.3.24_16705.20160509/runwpa rtl8188EUS_linux_v4.3.24_16705.20160509/wlan0dhcp

.......

rtl8188EUS_linux_v4.3.24_16705.20160509/platform/platform_ops.h rtl8188EUS_linux_v4.3.24_16705.20160509 Authentication requested [root] for make driver: make ARCH=armv7l CROSS_COMPILE= -C /lib/modules/3.1.10-gbe10973-dirty/build >M=/home/ubuntu/LM816_RTL8188EUS_LINUX_v4.3.24_16705.20160512/driver/rtl8188EUS_linux_v4.3.24_16705.20160509 modules make: * /lib/modules/3.1.10-gbe10973-dirty/build: No such file or directory. Stop. make: * [modules] Error 2

#

Compile make driver error: 2 Please check error Mesg

#

One strange thing is that /lib/modules/3.1.10-gbe10973-dirty/build actually exists, so I don´t know where the problem is.

Any help or suggestion is welcomed.

Thanks in advance,

Ander

0

With packaged kernels, /lib/modules/<kernel-version>/build is usually a symbolic link to where the necessary source files defining the details of the kernel module interface for this specific kernel version can be found.

You've confirmed that the link exists, but does its target exist? Is it something other than an empty directory?

On Debian/Ubuntu, to build kernel modules against a packaged kernel, you'll normally need to have the linux-headers-<kernel-version>_<package-version>_<arch>.deb package installed. That supplies the files that are supposed to be at the end of the /lib/modules/<kernel-version>/build symlink.

Run these commands:

cd /lib/modules/3.1.10-gbe10973-dirty
ls -ld build

and if buildis a symbolic link, you should see something like this:

lrwxrwxrwx 1 root root 34 Jan 25 08:42 build -> /usr/src/linux-headers-3.1.10-gbe10973-dirty/

Then your next step is to check whether or not the directory listed on the right side of the -> arrow exists or not. If it doesn't exist, you probably need to install a package whose name would be linux-headers-3.1.10-gbe10973-dirty.dpkg or something similar.

  • Thanks for helping @telcoM. How can I confirm that the target exist, I am quite new with linux. – Andermutu Jan 29 '18 at 17:57
  • Edited my answer. – telcoM Jan 29 '18 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.