4

I recently bought a new laptop:

  • Lenovo IdeaPad 320e
  • Intel i5 7200 2.5 GHz processor
  • 8 GB RAM
  • 2 GB Nvidia 940mx graphics
  • 1 TB HDD

It came with FreeDOS, so I installed Windows 10 on it on EFI mode.  A few days later, I also installed Kali Linux in a new partition from a live USB on EFI.

Partitions on my HDD:

  • Partition 1: Windows Boot (I guess) - 450 MiB
  • Partition 2: Windows Recovery (I guess) - 100 MiB
  • Partition 3: Windows reserved (I guess) - 16 MiB
  • Partition 4: Windows C: Drive - 299 GiB
  • Partition 5: Local NTFS E: Drive - 200 GiB
  • Partition 6: Local NTFS F: Drive - 382 GiB
  • Partition 7: EFI Grub Boot Loader - 477 MiB
  • Partition 8: Linux Swap - 9 GiB
  • Partition 9: Kali Linux (HFS+ partition) - 40 GiB

(See screenshot of EasyBCD display of partition configuration data.)

When I installed Kali for the first time (i.e., reboot after installation), I got the GRUB menu to start Kali Linux, so I know that Kali is properly installed.

So, the next time, I selected Windows Boot Loader to enter Windows 10.

The problem is now that there is no record of Kali Linux in my boot loader.  When I enter the boot menu, I can only see EFI on Network and Windows Boot Loader.  There is no GRUB.

I have already tried:

  1. Using bcdedit:

    bcdedit /set {bootmgr} path /EFI/Kali/grub64.efi
    

    Doesn't work; shows no such directory.

  2. Using live USB to reinstall GRUB:

     mount /dev/sda3 /mnt
     mount –bind /dev /mnt/dev
     mount –bind /dev/pts /mnt/dev/pts
     mount –bind /proc /mnt/proc
     mount –bind /sys /mnt/sys
     chroot /mnt
     grub-install /dev/sda
     update-grub
     exit
     umount /mnt/dev/pts
     umount /mnt/dev
     umount /mnt/proc
     umount /mnt/sys
     umount /mnt
    

    After reinstalling GRUB, the GRUB menu worked until I rebooted to Windows Boot Loader, after which it again showed no signs of Kali Linux.

  3. Reinstall Kali.

So my main problem is that, when I install Kali, I see the GRUB menu, but when I use Windows Boot Loader once, it always boots into Windows 10 and doesn't show Kali anywhere in my boot section.

Any help is appreciated.

Update:
I tried re-downloading Kali3 and then reinstalling.
I did the Standard Installing process, and now, thankfully, the Kali entry is showing in the boot manager.  Now the problem is GRUB doesn't boot.
I still haven't tried reinstalling GRUB, which hopefully will solve my problem.

I will keep everyone updated if reinstalling GRUB works.

P.S.: Looks like I accidentally installed GRUB on the same partition as the Windows Bootloader, but Windows Bootloader still works, so it didn't overwrite anything.

7 Answers 7

3

The Problem is Finally Solved.

What I did is simply installed Ubuntu alongside windows and guess what in the grub of Ubuntu, Kali was already listed.

Now i am using triple boot.(Win10, Kali and Ubuntu)

2
  • 2
    Wow! Did not see that coming! Congratulations! Both Question and answer upvoted! Please take a system backup (all HDDs) using CloneZilla live Disk to image...
    – Fabby
    Commented Sep 18, 2018 at 13:32
  • A separate swap partition is declassé ever since the 4.2 kernel. A swap file in /home runs just as fast, and gives you more flexibility in upsizing the swap file from the standard of 'make it the same size as your RAM to start and make it bigger if your apps use it'.
    – K7AAY
    Commented Jun 25, 2019 at 17:30
0

I would answer in a comment if i was able to, but probably you just need to disable secure boot, i had the same problem when i installed kali.
also how did you install kali?
did you install with a usb drive? i would recommend using rufus to set up the drive for installation.
you also might wanna take a look here, which was the first result on my google search. https://forums.kali.org/showthread.php?271-How-to-EFI-install-Kali-Linux
you could also try to enable legacy mode in your bios or put the efi files mentioned in that post from the above link to your usb drive which you probably used to install kali and then reinstall.

2
  • I am not new to dual booting so i already turned those settings off. Commented Jan 27, 2018 at 2:36
  • Kali doesn't seem to install on Legacy. Btw i updated the question. Commented Jan 31, 2018 at 17:04
0

This looks like a problem with UEFI firmware boot settings: either Windows or the firmware itself is probably deleting the UEFI boot option for Kali's GRUB.

First, you need a Windows tool that can view and edit the firmware-level UEFI boot settings, not just the Windows BCD. I would suggest EasyUEFI: https://www.easyuefi.com/index-us.html

I would suggest reinstalling Kali once more so that you can get to it, then run "efibootmgr -v" and print out its output or save it somewhere you can access in Windows. You could then boot to Windows, use EasyUEFI to see if the Kali setting has gone missing, and try reconstructing it and see what happens then.

Once you know what the boot entry should actually be, you can read this for more ideas on making it stay (it's written for the rEFInd boot manager, but it has the exact same problem with some vendors' UEFI firmware): http://www.rodsbooks.com/refind/bootcoup.html

1
  • Except for the reinstalling part(which helped a bit) the process in the link didn't work. I have updated the question with the new problem. If you have the solution then please help Commented Jan 31, 2018 at 17:06
0

Try going into Boot Manager (F12 or if you have Fn key press Fn+F12) and select the Kali Linux Drive (But don't start SWAP) if you want running Kali Linux first when you start your machine, go to BIOS, section 'boot' and make Kali Linux disk startup at first (+ and - keys I think).

0

There is no need to install a third OS(like Ubuntu or otherwise).

Assuming that your boot mode is UEFI. I had the same problem.

Just install both the operating system normally, one top of another. Boot to Windows and install easyUEFI and open it. It should be something like this.. Go to the left one enter image description here

Now adjust the boot sequence as your like. To boot with GRUB just bring Kali to the first

enter image description here

Hope it helps.

0

My answer is simple, But not usefull for daytoday use. Just restart user pc using shift+restart then choose advance boot option in there you can see kali (Linux) under USB device tab

And The most Easy way is use UEFI Editer

Just disable your windows 10 boot option and move kali to top(Working with windows 10).

If Above not working means use This Boot manager Repair tool (This should works with windows 8/8.1)

Checked with only Debian/ Ubuntu Based OS

0

I just had a similar issue. Had the dual boot setup (Windows 10 + Kali Linux), and after my laptop's BIOS update the record of Kali in BIOS completely disappeared. I got it solved thanks to the answers from Debu Shinobi and telcoM above. However there's no need to reinstall any of the systems.

Using EasyUEFI mentioned above I browsed the current EFI Boot Options, there was no Kali in there. So I used the 'Create a new entry' button.

EasyUEFI-1

Make sure to select your Kali's EFI partition in the next window (in my case it's on the second SSD) and the 'Linux or other OS' option in the upper part. Then simply use 'Browse' to find the path to your grubx64.efi file (\EFI\kali\grubx64.efi by default). Type in description that will indicate this record in your Boot menu ('Kali Linux').

EasyUEFI-2

After adding the entry you can adjust the order to boot into Kali primarily. Hope this can help anyone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .