2

I redid my i3bar recently with conky. This morning when I woke up the there were un-recognized characters symbols in my bar (where there are spaces in my conkyrc file)enter image description here. Nothing has really changed to my knowledge and I am not sure why this happened overnight. My conkyrc:

background no
out_to_x no
out_to_console yes
update_interval 1
total_run_times 0
use_spacer right

TEXT
${if_mpd_playing}${mpd_artist}   ${mpd_title}${endif}          \
  ${wireless_essid wlp7s0}          \
  ${exec amixer get Master | sed -n 's/^.*\[\([0-9]\+\)%.*$/\1/p'| uniq}          \
  ${cpu cpu}%          \
  $memperc%          \
  ${time %a %b %d}          \
  ${time %I:%M %P}          \
  ${battery_percent BAT0}% ${exec acpi -b | awk "{print $1}" | sed 's/\([^:]*\): \([^,]*\), \([0-9]*\)%.*/\2/'}          

And my i3bar config:

bar {
        status_command conky -c $HOME/.i3/conky/conkyrc
        mode dock
        position top
colors {
        background #F1F2F6
        statusline #788491
        separator #51c4d4

        focused_workspace  #F1F2F6 #F1F2F6 #4FC0E8
        active_workspace   #F1F2F6 #F1F2F6 #4FC0E8
        inactive_workspace #F1F2F6 #F1F2F6 #C1D1E0
        urgent_workspace   #F1F2F6 #F1F2F6 #C1D1E0
    }
}
  • The lines in your post after TEXT start with a weird character in column 1. Is this an artifact of your copy/paste, or actually in the file? Try cat -vet conkyrc to check for non-printing chars. – meuh Jan 25 '18 at 16:49
  • Those are icons. This is the out of the vet pastebin.com/2wNnqa5K – akhilcjacob Jan 25 '18 at 17:28
  • U+0020 (presumably what the box with 0020 means) is the character code for space. Odd that it'd being displayed as a replacement character instead of a space... – derobert Jan 25 '18 at 17:43
  • Ok. My browser doesn't have the right fonts. You might try running conky with --debug or -D -D to see if it has any warnings. Note if you have conky version 1.10 it will be autoconverting your file to the new format. – meuh Jan 25 '18 at 17:46
2

Found the answer: updating the awesome font seemed to fix it.

pacaur -S awesome-terminal-fonts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.