0

I cannot login anymore on my computer running Debian stretch. After I enter the password the login screen disappears and it looks like it's going to login but it eventually goes back to the login screen.

It happened after I installed mtrack following the steps described on this blog: The almost perfect touchpad settings on linux

I can login if I press CTRL ALT F2 and type my username and my password. At first after logging in this way there was a message saying:

bash- /usr/share/defaults/etc/profile is not a file or a directory.

So I copied the file profile in /usr/share/base-files/profile and put it in /usr/share/defaults/etc/profile and now it welcomes me with a message saying:

bash- /usr/share/defaults/etc/profile is a file or directory

but I still can't login.

As I said it happened after I followed the steps shown on the blog linked above and it seems it has something to do with xserver (after the installation it recommends to reboot the computer to restart xserver and that's when my problem started.)

I tried the suggestions in the links below but nothing worked for me.

Cannot login to Ubuntu after startx command

Cannot get past login screen

The file .Xauthority is owned by me and not root, so it's not this.

I reinstalled xserver as suggested on one of the links but it didn't work.

I'm sure my password is correct because 1) I can login in terminal mode 2) It shows an error when I enter an incorrect password.

I have GNOME3 installed.

closed as off-topic by Jeff Schaller, Rui F Ribeiro, Archemar, mdpc, sebasth Jan 30 '18 at 7:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Rui F Ribeiro, Archemar, mdpc, sebasth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • "is a file or directory", does it really say that? It's probably something wrong with one of you shell's startup files. Log in as root and see if you can spot what's changed in you user's .bashrc and/or .bash_profile (if you're using bash). – Kusalananda Jan 25 '18 at 14:12
  • Actually it says "Is a directory". Proof: imgur.com/9mYh0vv. And content of the /usr/share/defaults/etc/profile: imgur.com/3XPqS18. Content of my bashrc (i don't have a bash_profile): imgur.com/tKJiJMR – Jordanish Jan 25 '18 at 14:27
  • Hmmm... if source says it's a directory but you can view it as a file, then I'm not sure what's going on. Remove (comment out) the source from your bashrc file for now until you've figured out what's wrong with /usr/share/defaults/etc/profile. – Kusalananda Jan 25 '18 at 14:31
  • Have you put the file in /usr/share/defaults/etc/profile or copied it as /usr/share/defaults/etc/profile. I have a feeling that the path to the profile is /usr/share/defaults/etc/profile/profile – Raman Sailopal Jan 25 '18 at 14:56
  • @RamanSailopal Yes you're right. I created a directory 'profile' in which I put the file profile. Now I deleted it and put the file profile in /usr/share/defaults/etc/ but it doesn't solve the problem. I'm still unable to log in from the GNOME start menu. I think I better reinstall Debian, I just installed it last week anyway. But I'm curious about what happened. I changed the rights of the files .Xauthority and .ICEauthority originally -rw------- to -rwx------ to give execution rights to the owner (my username, it's something I read on another thread) but it didn't solve the problem either. – Jordanish Jan 25 '18 at 15:32
1

Here is the solution. The blog post I linked in my original message says I should create a file named 50-mtrack.conf with the content provided as an example and put it in /usr/share/X11/xorg.conf.d/. I deleted this file and now I'm able to login normally.

Not the answer you're looking for? Browse other questions tagged or ask your own question.