1

I am currently attempting to install Anaconda on my Linux shell. I download and check the hash code of my downloaded file, provide a directory and so on. However, my Unix refuses to execute the script. Once I type

$ sudo bash Anaconda3-5.0.1-Linux-x86_64.sh

the prompt gives:

ERROR: did not recognize option '', please try -h

-h gives nothing relevant. I tried this with a x32 and Python 2.7 versions as well, to rule out incompatibility of version in the environment.

As far as I can find, I can not need any pre-installed software. On Ask Ubuntu, I found that I needed the buns package, which I installed but nothing improved. The buns package is probably required for actual functioning of the program.

Is there anyone who can help me out? I am not sure what the error means or how it is constituted, as it provides me with no information.

  • What is your output of which getopt ? – hg8 Jan 25 '18 at 10:05
  • try without sudo first. – Gerard H. Pille Jan 25 '18 at 10:23
  • @GerardH.Pille; I have tried this without sudo, but similar results are obtained. I thought sudo-rights were the problem at first @hg8 I get this; PROMPT: /usr/bin/getopt: line 19: syntax error near unexpected token {' /usr/bin/getopt: line 19: local({' – RvB Jan 25 '18 at 11:03
  • what is the first line of Anaconda3-5.0.1-Linux-x86_64.sh ? – Gerard H. Pille Jan 25 '18 at 11:56
  • Hi @GerardH.Pille; the first line reads; #!/bin/sh I assume that the coding is correctly downloaded, because the hashes are identical, though. But maybe you can do something with this information. – RvB Jan 25 '18 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.