I have Fedora 12 running on my VMware. I am unable to see any options to enable WIFI connection on Fedora. When I am accessing Internet through WIFI and its working perfectly fine on Windows 7 (on which VMware is running on). Am I missing something here?


VMware will translate your wireless cards on the host to wired cards that are available to the guests. The only type of network card that you will be able to add to the guest is a hardwired card.

What you most likely want to do it setup the Fedora guest to use "Bridged" networking mode, and then config fedora to use DHCP.

Assuming (bad I know), that you are running VMware workstation on Windows 7:

Bridged networking guide

According to the Fedora Networking guide Fedora has NetworkManager set to DHCP by default, click the link to read more.

  • Hi Tim, Can you please guide me to a place which explains about setting up Bridged network mode and configuring Fedora to use DHCP.. – msumaithri Jun 29 '12 at 17:17
  • Check out the updates in my answer. Added 2 links for yah. – Tim Jun 29 '12 at 17:23
  • Glad to help! I am a VM junkie :) – Tim Jun 29 '12 at 20:05

Here is a simple way to connect with your WIFI -

  1. Click on Edit from the menu section
  2. Virtual Network Editor
  3. Change Settings
  4. Add Network
  5. Select a network name
  6. Select Bridged option in VMnet Information -> Bridge to : Automatic
  7. Apply

That's it. You might be asked the password to connect to network. Add it and you would be able to connect to the network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.