0

I have a USB drive connected to my router to access files remotely, and it can use ftp to connect (not ssh or sftp). I have the router login set to the same login as my desktop computer, and I can use Nemo to connect to the server for file transfers only if I set the ftp login to use the same login as my main router login.

But, I have the option to set up an alternate login, which I'd like to do so I don't need to give out the router login to anyone. However, Nemo will not connect using either "Connect to server" or typing in a URL in the address line. It will only connect if the login name and password are the same as the computer. I believe there is some protocol for using your existing login for an external device.

It's obviously not the router, as I can connect as expected using my phone's file manager (FX on Android).

EDIT: I tried using a windows share option, and had the same problem. Something about sending the login information doesn't work, except when it's the system's login info. Even using user:password@address doesn't work; it prompts for a password, but the command it sends is screwed up.

0

I use this format to access my Android tablet:

  • sftp://192.168.xx.yy:2222/storage/extSdCard/Movies

The ftp server (on the Android) doesn't have root access so can't use port 22.

  • Thanks, but that doesn't work in this situation, which is that this uses SSH, which isn't available. Also, the problem isn't connecting, the problem is entering a password on the remote server. I can connect fine if the remote server has the same password as my local computer. – Marty Fried Mar 17 at 0:31
  • @MartyFried hi ya. the same url should still work with ftp:sftp://192.168.xx.yy but as you say connecting is your problem. Pity you can't put ssh on the router. good luck – will Mar 18 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.