1

I use tmux frequently but on one particular machine in one computer cluster, when I use tmux the working directory is changed to / and I am unable to access my home directory. I have checked that I am still the same user by running whoami, and that $HOME has not changed, but I still get permission denied when trying to cd home. When I quit tmux I can access my home directory with no issues.

This problem is only on one particular machine in the cluster, and other machines that share the same file system do not present this problem. Any ideas why this is happening? Thank you.

  • I think it is due to a chrooted environment on that particular cluster member for this login. You may use root account or sudo commands to check history & confirm or not that hypothesis – francois P Jan 24 '18 at 21:21
  • is the home directory shared across all machines in the cluster (e.g. via NFS)? if not, you might have a chroot command in your ~/.tmux.conf on that machine. or tmux might be aliased or wrapped in a function or script to run chroot first. – cas Jan 24 '18 at 23:27
  • @cas yeah its a shared NFS directory – Jon Deaton Jan 24 '18 at 23:33
  • 1
    ok, then check what is actually being run when you start tmux. start with type -a tmux , then examine each pathname, or function, or alias that it mentions. also check the system-wide tmux config file, typically /etc/tmux.conf - if that's different to the one on other cluster machines, report it to the cluster admins. – cas Jan 24 '18 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.