I have issues unzipping a huge zip files containing around 1M files. The zip file is 15GB and uncompresses to ~60GB. When I run unzip file.zip -d /directory/to/unzip/at it uncompresses halfway and gives up at around 700K files. No error messages.

Any tips?

  • use 7zip to uncompress it – Rui F Ribeiro Jan 24 '18 at 20:08
  • Same results, I tried with 7za – Anon Jan 24 '18 at 20:40

I suspect urilimit set limit for either file size or CPU time: urilimit man page

  • They're both marked as "unlimited" – Anon Jan 24 '18 at 19:34
  • Does the unzipping stop at the exact same time? Is the unzipped content with the same size every time? – Georgi Tsvetanov Tsenov Jan 24 '18 at 19:48
  • The unzipping stops at the exact same file every single time. Also unzipping the content produces the same amount of files/size. So you're right there seems to be a limiter. But it says "unlimited". – Anon Jan 24 '18 at 20:40
  • what filesystem are you decompressing the files to? – D'Arcy Nader Jan 24 '18 at 20:52
  • 1
    @D'ArcyNader ext4 – Anon Jan 24 '18 at 20:55

This happened to me (same symptoms, where it would hang after the same file every time). It turned out that stdout was being redirected somehow, so I wasn't seeing a prompt about overwriting a pre-existing file. Try running unzip with the -o option, and/or avoid stdout shenanigans.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.