0

Wel I'm a manjaro linux user and I hadn't updated it for probably months, I use version 233. So I recently updated with this command:

sudo pacman -Syyu

But after the update the screen locker was broken and I couldn't log in to a graphical environment, so I tried to fix it in a virtual terminal, but I had network problems so now I use live-media and I'm trying to fix it via chroot. But now I still have network problems: I can ping 8.8.8.8 but not any website, and I fail to download any package or refresh my mirrorlist. When I type this:

systemctl restart NetworkManager

or

systemctl restart NetworkManager.service

I get this:

Running in chroot, ignoring request.

So I need your help.

  • can you set up your network with the live media before chrooting? – Stefan Jan 24 '18 at 13:03
  • That's what I did. – Matin N. Jan 24 '18 at 13:10
  • so it's working in the live environment and stops working in chroot? have you used manjaro-chroot to change root or just chroot? – Stefan Jan 24 '18 at 13:17
  • yes, network works in the live environment. I used chroot. – Matin N. Jan 24 '18 at 13:20
2

If by "website" you mean "I can't ping anything by name rather than by IP address", it means you have a broken DNS configuration.

Check if your NetworkManager configuration overrules DNS settings. If it does not, then check if /etc/resolv.conf contains a line that starts with nameserver and that contains a DNS IP address. If not, either fix the NetworkManager configuration, or your resolv.conf.

  • well the only thing I have in /etc/resolv.conf is this : Generated by resolvconf How can I fix it? What should I add to it? – Matin N. Jan 24 '18 at 13:13
  • usually /etc/resolv.conf should be the same as in the live environment, if it works in the live environment. that's one of the things manjaro-chroot normally takes care of, when you change root. – Stefan Jan 24 '18 at 13:18
1

Please update /etc/resolv.conf with nameserver entry as follows

sudo vim /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4

Then restart network. If this works consider adding the nameserver entries in your interface setting to avoid doing it manually each time after connection establishment.

You can change interface settings either from GUI (if you've) or by editing OS Dependent configuration file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.