1

I am using a dual boot system with windows 10 and Linux mint 18.1. I have three partitions on my hard disk. Using Windows I am able to access C and D with OS on C partition. However, when I boot to Linux I am not able to access D partition. I have saved most of my work in D drive. In the file system it shows D drive but when I click on it following pop up appears


Error mounting /dev/sda2 at /media/legend/2076AD4776AD1F12: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/legend/2076AD4776AD1F12"' exited with non-zero exit status 14: Windows is hibernated, refused to mount. Failed to mount '/dev/sda2': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.


I am sure that I have not hibernated from windows. It is cumbersome to restart windows to get a specific file.

4
  • 1
    Have you tried to mount it read only? Commented Jan 24, 2018 at 7:26
  • How can I do that?
    – Ehsa
    Commented Jan 24, 2018 at 7:28
  • 2
    man mount would tell you ro Mount the filesystem read-only. So add ro to your -o options Commented Jan 24, 2018 at 7:31
  • 1
    Is this due to hibernation of your windows ?? test whith a real windows extinction to validate or no that point.
    – francois P
    Commented Jan 24, 2018 at 7:50

1 Answer 1

3

This is due, as the error indicates, to Windows either hibernating or performing a fast reboot. Since you can access the partition which holds C, it did not hibernate, hence, I guess Windows performed a "fast" restart and did not unmount the partition D cleanly in the process. To avoid this, you choose "Shutdown" in Windows, NOT "Restart". If you want to use "Restart" you disable "Fast Startup" as follows:

Control Panel > Hardware and Sound > Power Options > Change what the Power buttons do

You will have to click "Change Settings that are currently unavailable" if "Turn on fast startup (recommended)" is greyed out.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .