0

How to install a Latex distribution on Ubuntu 17.04?

I tried:

sudo apt install --fix-missing texlive-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  apt-show-versions debugedit libauthen-pam-perl libblas-common libblas3 libgfortran3 liblapack3 libqt4-designer libqt4-help libqt4-scripttools libqt4-test
  libqtassistantclient4 libqwt5-qt4 librpmbuild3 librpmsign3 libsqlite0 linux-headers-4.10.0-37 linux-headers-4.10.0-37-generic linux-headers-4.10.0-38
  linux-headers-4.10.0-38-generic linux-image-4.10.0-37-generic linux-image-4.10.0-38-generic linux-image-extra-4.10.0-37-generic
  linux-image-extra-4.10.0-38-generic python-libxml2 python-lzma python-numpy python-pycurl python-qt4 python-rpm python-sip python-six python-sqlite
  python-sqlitecachec python-urlgrabber rpm
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  fonts-lmodern libpotrace0 libptexenc1 libsynctex1 libtexlua52 libtexluajit2 libzzip-0-13 lmodern tex-common texlive-binaries
Suggested packages:
  debhelper perl-tk
The following NEW packages will be installed:
  fonts-lmodern libpotrace0 libptexenc1 libsynctex1 libtexlua52 libtexluajit2 libzzip-0-13 lmodern tex-common texlive-base texlive-binaries
0 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 23,8 MB/38,0 MB of archives.
After this operation, 126 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 libpotrace0 amd64 1.13-3
  404  Not Found
Err:2 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 libptexenc1 amd64 2016.20160513.41080.dfsg-1
  404  Not Found
Err:3 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 libsynctex1 amd64 2016.20160513.41080.dfsg-1
  404  Not Found
Err:4 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 libtexlua52 amd64 2016.20160513.41080.dfsg-1
  404  Not Found
Err:5 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 libtexluajit2 amd64 2016.20160513.41080.dfsg-1
  404  Not Found
Err:6 http://pl.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libzzip-0-13 amd64 0.13.62-3ubuntu0.17.04.1
  404  Not Found
Ign:7 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 tex-common all 6.06
Err:8 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 texlive-binaries amd64 2016.20160513.41080.dfsg-1
  404  Not Found
Ign:9 http://pl.archive.ubuntu.com/ubuntu zesty/main amd64 texlive-base all 2016.20170123-5
Err:7 http://pl.archive.ubuntu.com/ubuntu zesty/main i386 tex-common all 6.06
  404  Not Found
Err:9 http://pl.archive.ubuntu.com/ubuntu zesty/main i386 texlive-base all 2016.20170123-5
  404  Not Found
Err:6 http://security.ubuntu.com/ubuntu zesty-security/main amd64 libzzip-0-13 amd64 0.13.62-3ubuntu0.17.04.1
  404  Not Found
Unable to correct missing packages.                    
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/p/potrace/libpotrace0_1.13-3_amd64.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/texlive-bin/libptexenc1_2016.20160513.41080.dfsg-1_amd64.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/texlive-bin/libsynctex1_2016.20160513.41080.dfsg-1_amd64.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/texlive-bin/libtexlua52_2016.20160513.41080.dfsg-1_amd64.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/texlive-bin/libtexluajit2_2016.20160513.41080.dfsg-1_amd64.deb  404  Not Found
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/z/zziplib/libzzip-0-13_0.13.62-3ubuntu0.17.04.1_amd64.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/tex-common/tex-common_6.06_all.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/texlive-bin/texlive-binaries_2016.20160513.41080.dfsg-1_amd64.deb  404  Not Found
E: Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/main/t/texlive-base/texlive-base_2016.20170123-5_all.deb  404  Not Found
E: Aborting install.

It's not present in Ubuntu Software.

PS. I know that Ubuntu 17.04 is unsupported but it's the only version which worked with my GTX 960. MAYBE newer version are fixed now but I don't want to risk bricking by laptop again.

  • Ubuntu specific questions should be asked on askubuntu.com – Rob Jan 23 '18 at 14:24
  • Your apt cache does not seem fresh anymore, start by refreshing it: apt-get update – Patrick Mevzek Jan 23 '18 at 14:26
  • It would be nice if it printed a message "you cannot install or update anything because we want you to upgrade your distributeion". I've posted an answer to my question. Sorry for trouble. – Lutosław Jan 23 '18 at 14:48
0

OK, for anybody who has the problem.

When a version of Ubuntu is not supported, packages are moved to new locations and there are 404 errors. After upgrading, you can install and update packages normally.

Fortunately, it upgraded to 17.10 seamlessly and it works with GTX 950 out-of-the box now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.