0

I want to configure an IP camera which is in my raspberry pi's ethernet port (I connect to it through wifi).

I connected the camera and this is what I see when I run ifconfig

eth0      Link encap:Ethernet  HWaddr b8:27:eb:a2:10:08  
          inet addr:169.254.248.2  Bcast:169.254.255.255  Mask:255.255.0.0
          inet6 addr: fe80::ce99:232c:964e:7070/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5600 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27715 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3219770 (3.0 MiB)  TX bytes:10481558 (9.9 MiB)

So it means my raspberry pi has the IP address 169.254.248.2. I tried accessing 169.254.248.1 and scanning with nmap 169.254.0.0/16 but the only host up that I see is the raspberry pi itself.

I then run tcpdump on eth0:

tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
03:13:53.963493 IP (tos 0x0, ttl 64, id 13074, offset 0, flags [none], proto UDP (17), length 368)
    0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from b8:27:eb:a2:10:08 (oui Unknown), length 340, xid 0x252200b7, secs 65535, Flags [none]
          Client-Ethernet-Address b8:27:eb:a2:10:08 (oui Unknown)
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            Client-ID Option 61, length 7: ether b8:27:eb:a2:10:08
            SLP-NA Option 80, length 0""
            NOAUTO Option 116, length 1: Y
            MSZ Option 57, length 2: 1500
            Vendor-Class Option 60, length 44: "dhcpcd-6.7.1:Linux-4.9.48-v7+:armv7l:BCM2835"
            Hostname Option 12, length 11: "raspberrypi"
            T145 Option 145, length 1: 1
            Parameter-Request Option 55, length 14: 
              Subnet-Mask, Classless-Static-Route, Static-Route, Default-Gateway
              Domain-Name-Server, Hostname, Domain-Name, BR
              NTP, Lease-Time, Server-ID, RN
              RB, Option 119

Which looks like my raspberry pi is trying to find an IP to itself. I didn't hear anything from the camera. Shouldn't I get its broadcast messages trying to get an IP?

Ok, so I continued and installed https://help.ubuntu.com/community/isc-dhcp-server with the following configuration file:

# Sample /etc/dhcpd.conf
# (add your comments here)
default-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 169.254.248.255;
option routers 169.254.248.254;
option domain-name "mydomain.example";

subnet 169.254.248.0 netmask 255.255.255.0 {
range 169.254.248.10 169.254.248.100;
}

It should make the dhcp client of the camera request an address and get 169.254.248.10, right?

None of this worked, so I started to remember a few things about this camera:

They come preconfigured to work at 192.168.1.x, and with a fixed IP (which I don't know what is).

Does this mean that the camera will never work at my ethernet port, unless I make the ethernet address be in the 192.168.1.x range?

Shouldn't I receive broadcast messages from the camera, even if I'm on a different subnet and even if its IP is fixed? I think I should received ARP brocadcast messages informing in which IP it is, something like that, right? Yet I don't hear anything coming from the camera when I do tcpdump -i eth0

If the answers to these last two questions are false, then can I make my ethernet port work on the 192.168.1.x range, even though my wlan0 interface is already working on it? (I mean, could I at least do it in a virtual way just to talk with the camera? Since it's raw ethernet, I could fake that eth0 is on 192.168.1.x just to fool the camera). I'm asking this because all I'm doing is remote, I can't mess with the wlan configurations, and can't put it into a different subnet.

  • 1
    Why don't you just plug both your pi and the camera into DHCP enabled switch ports and establish working communication and baseline information before starting to debug in the dark – hmedia1 Jan 23 '18 at 3:55
  • @hmedia1 I tried. Since the camera comes from the manufacter with a fixed IP, it won't appear in my router's DHCP list. I also don't know its MAC address, so I can't find which one it is in the ARP list (I even think that it's not there). I then get lost and can't find it. Do you have any ideas? – Guerlando OCs Jan 23 '18 at 3:59
  • if it comes with a fixed IP, all you need to do is make sure you're on the same subnet if a different IP, and then connect to the camera. – hmedia1 Jan 23 '18 at 4:26
  • @hmedia1 but I don't know its IP – Guerlando OCs Jan 23 '18 at 4:40
  • Did you ever figure out how to get this to work? – dbainbridge Apr 18 at 2:11
1

With no hub or switch you need to use a crossover cable. You can make a cable that is crossed, make a cable with a female RJ45 connector that is crossed, put 2 RJ45 connectors together (a 2 port hub!), etc.

Once that is done the automatic addressing may work, or check the manual for the camera it may have a default static IP set.

If you know the IP is in the 192.168.1.x subnet, set your Pi to something in that range and then port scan or ping scan the subnet.

ifconfig eth0 192.168.1.131 netmask 255.255.255.0
  • what is this command you typed? Also, could you explain a little more about the crossed cable and why a normal one wouldn't work? – Guerlando OCs Jan 23 '18 at 4:01
  • I just did route add and added the default gateway of 192.168.1.1 to see what would happen and now I lost connection to my raspberry which is hundreads of km away. Do you know if this command is permanent or will it be removed after reboot? Thank you so much – Guerlando OCs Jan 23 '18 at 4:02
  • Unlikely that they need a crossover cable. Either the camera or the pi probably has autosense. – jdwolf Jan 23 '18 at 4:47
  • @jdwolf I'm confused now. I just bought a cross cable though, let's see if I it works. Anyways, if normal cables work, then I should see the camera's output with tcpdump, right? – Guerlando OCs Jan 23 '18 at 4:56
  • It won't hurt to use one just in case. – jdwolf Jan 23 '18 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.