2

I've installed KALI 2017.3 in a virtual box VM.

I also installed the guest additions and upgraded all the graphics drivers available.

The auto-adjust feature is greyed out. As well as choosing resolution for the display (in the bottom right of the VM window, on the display icon)

The maximum resolution I can choose inside KALI, in the system configuration, is 1024x768.

What am I missing? What else can I try to get auto-adjust resolution feature working?


edit about the suggestion to mark as duplicate of Why is Kali Linux so hard to set up? Why won't people help me?

It turned out eventually, that this was because of a missing feature in the kernel version supplied with the current KALI iso image, which was not trivial from the issue and error messages. So, this question and answer could be helpful even to experts in KALI.

As a personal side-note, I disagree with notion that a question should not be asked if the subject is "expert level". Even experts could find themselves tackling an unusual issue that may appear to be basic. In fact, it's probably mostly experts.

  • 4
    Possible duplicate of Why is Kali Linux so hard to set up? Why won't people help me? – dirkt Jan 22 '18 at 21:20
  • The point is not about "beginner questions" or "expert questions", the point is that too many people are trying to use a distribution with a very specific purpose (penetration testing toolkit meant to be booted from an USB stick) in various ways it's not inteded for (e.g. installing it on a VM), and then they wonder that lots of stuff (graphics) doesn't work. All of this can be solved by simply using a suitable distribution instead of Kali. – dirkt Jan 23 '18 at 19:55
  • 1
    Kali is very much intended to be installed as a VM. I've done so before and from what I see it is mostly done that way rather than being booted from USB. More so, last time I installed it, guest additions worked out of the box. All that said, even if the question is about doing something that was not originally intended, it's still not suffice to say it is a bad question! (Javascript was not intended to run in server side, now we have nodejs) – Tom Klino Jan 23 '18 at 20:49
3

So I found that the guest additions service had failed to load. The error was related to DKMS modules failing to load. Googling a bit on that lead me to think it may be related to kernel version.

apt-get install linux-image-4.14.0-kali3-amd64

fixed the issue after rebooting

I also did

systemctl enable virtualbox-guest-utils.service

earlier, that might have also helped

  • 1
    Congrats. Please do not forget to accept your own answer in two days. – Rui F Ribeiro Jan 23 '18 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.