0

After updating Ubuntu Gnome 16.04 to Ubuntu 17.10, I started running into some problems. There were the semi-expected ones (like malfunction GUI features) that came with the merge of Ubuntu and Ubuntu Gnome, as well as the unexpected ones.

And the biggest one that I cannot seem to solve is why I can no longer boot from almost any Linux distro, which is a problem since I need to reinstall it for school.

I have tried many OSs and versions: Ubuntu 12.04, 16.04, and 17.10.1

Elementary OS

Fedora 27

And Puppy Linux. Which is interesting, because that one worked.

None of the Ubuntu based distros gave any error messages, but when I tried Fedora, it thankfully gave me some output - the first I have gotten:

3.616156] Couldn't get size: 0x800000000000000e
4.048773] Dracut-pre-udev[416]: rpc.idmapd: conf_reinit open ("(null)", )0_RDONLY) failed
4.049176] Dracut-pre-udev[416]: rpc.idmapd: conf_reinit open ("(null)", )0_RDONLY) failed

So it looks like something is read only, but I can't seem to figure out what. And the weird thing is that it is making my dual booted Windows 10 install misbehave as well. Strange bugs - the likes of which I rarely ever see, like failure to sign in.

There is one more bit of information that will hopefully be helpful. This is a new, Lenovo laptop, and with the big deal with Ubuntu 17.10 corrupting BIOS chips on many Lenovo computers, it has certainly crossed my mind that that could be the culprit, but I can still read and write to my BIOS (I updated it to the latest version and saved settings such as the time), and I can still boot some things from USB, like Puppy Linux as well as a Windows 10 iso.

Note that the Windows 10 boot has problems since it for some reason cannot detect any drive.

Upon running diskpart in Windows, it reports that everything on the SSD is fine and dandy, although I almost suspect that something is wrong here.

If any of you have any ideas or suggestions, they would be more than slightly appreciated :)

  • Ubuntu 17.10 didn't corrupt anything. It did a normal operation to the NOR flash which caused the BIOS to reset itself due to a bug in the BIOS. The error messages you posted are probably not directly related to the issue. Can I see more of your boot logs? – jdwolf Jan 22 '18 at 1:56
  • Unfortunately that's all the logs that I was able to glean from the system. They've been pretty few and far between. – j2997 Jan 22 '18 at 2:38
0

The kernel usually places the filesystem in read mode when it is damaged and/or it has inconsistencies.

Given your description of this happening with several Linuces, your disk is most probably dying, get a new one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.