2

I keep getting this error whnever I run sudo apt update

E: The repository 'http://archive.ubuntu.com/ubuntu wily Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I'm running ubuntu 16.04

lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:    16.04
Codename:   xenial

/etc/apt/sources.list https://pastebin.com/VUbWcT6J

/etc/apt/sources.list.d/* https://pastebin.com/25KiRH0F

  • so there is no updates for 16.04 and I should update to 16.10? – Nabil B Jan 20 '18 at 16:46
  • 3
    No, 16.04 is still supported, it’s Wily (15.10) which isn’t. Are you running 15.10, or 16.04? I’ll write up a proper answer... – Stephen Kitt Jan 20 '18 at 16:54
  • I'm running 16.04 – Nabil B Jan 20 '18 at 17:04
  • 2
    Please check the /etc/apt/sources.list.d with cat /etc/apt/sources.list.d/* – GAD3R Jan 20 '18 at 17:22
  • 1
    removed it and could update successfully, thanks – Nabil B Jan 20 '18 at 17:40
5

You’re getting that error because Wily (15.10) has reached the end of its life and has therefore been archived.

If you’re really running 16.04, you don’t need Wily repositories and you can remove them from your /etc/apt/sources.list file, or whichever file in /etc/apt/sources.list.d refers to Wuly. This will avoid the error you’re getting when running apt-get update. Alternatively, you can use old-releases.ubuntu.com instead of archive.ubuntu.com if you absolutely need the Wily repositories for some reason.

If you’re still running 15.10 however, you should upgrade to 16.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.