I've done yum install epel-release and this shows in my repolist:

repo id                                                     repo name                                                                                 status
base/7/x86_64                                               CentOS-7 - Base                                                                            9,591
epel/x86_64                                                 Extra Packages for Enterprise Linux 7 - x86_64                                            12,219
extras/7/x86_64                                             CentOS-7 - Extras                                                                            329
updates/7/x86_64                                            CentOS-7 - Updates                                                                         1,698

When I ask whether fail2ban is available, the answer is yes...

Available Packages
fail2ban.noarch                                                               0.9.7-1.el7                                                               epel

But when I install, it seems to attempt a different version and then has issues with an apparently too-new version of Python.

Error: Package: fail2ban-0.9.6-1.el6.1.noarch (epel)
       Requires: python(abi) = 2.6
       Installed: python-2.7.5-58.el7.x86_64 (installed)
           python(abi) = 2.7
           python(abi) = 2.7
       Available: python34-3.4.5-4.el6.i686 (epel)
           python(abi) = 3.4

It gives these two options to work around the problem, but I'm not sure how wise either of those is.

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
  • Odd, that looks like fail2ban from epel for centos 6, but repolist says 7 in the description.
    – jordanm
    Jan 20, 2018 at 6:30
  • Yes, and some of the Q&A I found mentioned similar and suggested uninstalling the repo, cleaning yum, and re-installing, which I did, but the result didn't change.
    – zkarj
    Jan 20, 2018 at 22:44

1 Answer 1


While checking for any package updates I noticed the epel repository was erroring with a 404.

Once again I removed the repository, cleaned, and re-installed. A different version of the repository resulted and my first attempt to install fail2ban completed successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .