yum install epel-release and this shows in my repolist:
repo id repo name status base/7/x86_64 CentOS-7 - Base 9,591 epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 12,219 extras/7/x86_64 CentOS-7 - Extras 329 updates/7/x86_64 CentOS-7 - Updates 1,698
When I ask whether fail2ban is available, the answer is yes...
Available Packages fail2ban.noarch 0.9.7-1.el7 epel
But when I install, it seems to attempt a different version and then has issues with an apparently too-new version of Python.
Error: Package: fail2ban-0.9.6-1.el6.1.noarch (epel) Requires: python(abi) = 2.6 Installed: python-2.7.5-58.el7.x86_64 (installed) python(abi) = 2.7 python(abi) = 2.7 Available: python34-3.4.5-4.el6.i686 (epel) python(abi) = 3.4
It gives these two options to work around the problem, but I'm not sure how wise either of those is.
You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest