2

I work on Fedora 17 entirely in CLI (or TUI) and I do not have a mouse. If I output something that is long I cannot scroll the lines.

I tried Ctr+Up, Ctr+Shift+Up, Ctrl+A as some sites suggest but none let me scroll the terminal.

Is there a universal way to let me scroll the terminal line by line?

1
  • There isn't a universal method, so this question is unanswerable. Nov 4 '16 at 22:33
6

Usually it is Shift+Page Up to scroll up and Shift+Page Down to scroll down.

2
  • Unless you switch desktops (VTs). Switching desktops clears the scrollback and it might seem like these keys have no effect.
    – Alexios
    Jun 28 '12 at 19:02
  • I'm running Fedora on VMWare on Macbook Pro which doesn't have page up or down key. The track pad doesn't scroll either. I also tried the fn key but no luck.
    – KMC
    Jun 30 '12 at 7:30
1

After trying various combination, it is fn + Shift + Up that works for me.

Environment: running Fedora 17 CLI/TUI on VMWare Fusion 3 on OS X 10.6.8 Snow Leopard.

2
  • 1
    As you said that you don't have a "Page up" key and considering that "fn + arrow up" corresponds to "Page up" on a Mac I think you made an error in your answer. Should it not be "shift + fn + up"?
    – Matteo
    Jul 18 '12 at 6:45
  • thanks @Matteo you are correct. Answers amended. Is Up, not Page-up
    – KMC
    Jul 18 '12 at 6:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.