2

When I try to use sudo apt-get update, I get the following error:

E: The repository 'http://de.archive.ubuntu.com/ubuntu zesty Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

what can I do to update Ubuntu correctly?

I'm on Ubuntu 17.04

7

Ubuntu 17.04 (Zesty) has reached the end of its life (see the releases page on the Ubuntu wiki for details), so it’s no longer available from the repositories.

You have two options:

  • upgrade to 17.10 (this is the better solution);
  • replace de.archive.ubuntu.com in /etc/apt/sources.list with old-releases.ubuntu.com.

The second option will allow apt-get update to finish, but you won’t get any new updates. In particular, you won’t get updates addressing Meltdown and Spectre.

  • 1
    Indeed @GAD3R, thanks, I wondered about that... – Stephen Kitt Jan 22 '18 at 9:20
0

Ubuntu 17.04 STS had a 9-month lifetime which expired a week ago. The Ubuntu people recommend upgrading to 17.10, which is another short-term support release. Your next LTS release will be 18.04, due later this year.

Further reading

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.