1

I was able to place the xscreensaver.desktop shown below in /usr/share/gdm/greeter/autostart to run xscreensaver at the login screen. I can see that the xscreensaver process is running as gdm user. When I try to activate xscreensaver I only get a blank screen and after moving the mouse I can see the gnome-shell clock. When I press enter I return to the login screen. Is there any troubleshooting methods I can use to help figure out why Xscreensaver is not working at the login screen?

Contents of xscreensaver.desktop:

[Desktop Entry]
Type=Application
Exec=/usr/bin/xscreensaver -nosplash
Hidden=false
Name=XScreenSaver
0

Download xscreensaver for Centos 7: yum install xscreensaver

Change directory to /usr/bin and execute the following to adjust your preferences: ./xscreensaver-demo

Change to your home directory and edit your .bash_profile; I use gedit: gedit .bash_profile

Make sure /usr/bin is included in your $PATH separated with a colon.

After the export PATH in your .bash_profile include the following line: xscreensaver -nosplash &

Save the file, exit and re-login.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.