0

I've got a samba shared directory which previously was setup normally but I noticed not being able to connect to it anymore. Turns out that permissions were reset to root and whenever I try to change it either with nautilus or with chown sambauser:sambashare directory it instantly resets permissions to root:root

What's happening here and how do I change it?

The directory path is /sharing/ and the permissions I want to set are sambauser:sambashare, it is also the samba server having this problem, not a samba client.

My only guess is that it might be due to the root-filesystem that the directory is inside, but that's only a guess.

  • How do you mount the directory? – Thomas Jan 19 '18 at 13:11
  • I use automount like this – HackXIt Jan 28 '18 at 11:07
2

The problem was in the way I setup the automount options.

I simply added uid and gid to my configuration and it worked again. It used root because it was inside the root filesystem, since nothing else was provided. Telling the configuration which user and group to use made it accessible by said user or group. Always nice to solve my own problems after enough digging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.