I have run the following command as root today morning

 sh /home/suio/LoadSnortSingature.sh > /home/suio/logs.txt 2>&1 
after some time the session of the terminal closed and I have relogged in again and did
 tail  -f /home/suio/logs.txt
it was stopped at certain point.After some time I blindly run again
sh /home/suio/LoadSnortSingature.sh
It says process is running, I have cross checked with ps and there was no process running this shell name and tried to kill using
 pkill -f  LoadSnortSingature.sh
but this didnot worked , I am still getting process is running message.I am using
Linux shio.jp 3.10.0-514.el7.x86_64 #1 SMP Tue Nov 22 16:42:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
How to kill the process?

closed as off-topic by Wildcard, Archemar, Jeff Schaller, jayhendren, dhag Jan 19 '18 at 21:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Wildcard, Archemar, Jeff Schaller, jayhendren, dhag
If this question can be reworded to fit the rules in the help center, please edit the question.

  • @Fox I performed the pkill as root. – chandu Jan 19 '18 at 7:45
  • 2
    Sorry When I went through the script I see they have locked the if [ -f ${LOCKFILE} ] ; then echo process is running exit 1 , I have cleared the lock file now I am able to run the script. – chandu Jan 19 '18 at 8:06

It looks like the script started some other processes which should have same ppid. Check zombies with

ps -elf | grep -v grep | grep Z

where Z is process your are looking for.

Then, sort processes by owner.

Not the answer you're looking for? Browse other questions tagged or ask your own question.