0

I installed fedora 20 64bit to my PC along with Win 10 in duel boot and then tried to install Chrome browser according to this article, but I get below error when executing the last command. [sudo yum install google-chrome-stable]

Loaded plugins: langpacks, refresh-packagekit google | 3.0 kB 00:00 http://dl.google.com/linux/rpm/stable/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for google: Damaged repomd.xml file Trying other mirror. Error: failure: repodata/repomd.xml from google: [Errno 256] No more mirrors to try. http://dl.google.com/linux/rpm/stable/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for google: Damaged repomd.xml file

Then I tried the URL (in above error message) in my browser(firefox) and got following error

Application Blocked! You have attempted to use an application which is in violation of your internet usage policy. Yum.Tool Category: Update URL:http://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/repomd.xml Client IP: 192.168.20.36 Server IP: 74.125.200.136 User name:

I tried that same url in windows (same pc & same network settings in duel boot) then it's working (can download a xml file)

What could be the problem here ?

EDIT -

I tried updating firefox and get the same error message as above.

  • Fedora 20 is ancient.Please consider installing a more recent version. Fedora 27 is the current version. – NickD Jan 19 '18 at 4:23
  • 2
    The problem is not with Fedora 20 definitely. Check the "internet usage policy" with your ISP – Serge Jan 19 '18 at 4:25
  • No I think the problem is within my OS – Sameera.San Jan 19 '18 at 6:07
0

The Fedora 20 is not guilty. Although I had to install the nss from Fedora 24's release as google-chrome-current requires NSS of version 3.28 or above, all other packages come from Fedora 20:

-bash-4.2# rpm -q fedora-release nss
fedora-release-20-4.noarch
nss-3.30.2-1.0.fc24.x86_64
-bash-4.2# yum install https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm
google-chrome-stable_current_x86_64.rpm                                                                                                                                                                                |  47 MB  00:00:04     
Examining /var/tmp/yum-root-BRyfCa/google-chrome-stable_current_x86_64.rpm: google-chrome-stable-63.0.3239.132-1.x86_64
Marking /var/tmp/yum-root-BRyfCa/google-chrome-stable_current_x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:63.0.3239.132-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================================================================
 Package                                                   Arch                                        Version                                                Repository                                                                 Size
==============================================================================================================================================================================================================================================
Installing:
 google-chrome-stable                                      x86_64                                      63.0.3239.132-1                                        /google-chrome-stable_current_x86_64                                      177 M

Transaction Summary
==============================================================================================================================================================================================================================================
Install  1 Package

Total size: 177 M
Installed size: 177 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : google-chrome-stable-63.0.3239.132-1.x86_64                                                                                                                                                                                1/1 
Redirecting to /bin/systemctl start  atd.service
  Verifying  : google-chrome-stable-63.0.3239.132-1.x86_64                                                                                                                                                                                1/1 

Installed:
  google-chrome-stable.x86_64 0:63.0.3239.132-1                                                                                                                                                                                               

Complete!
-bash-4.2# 

So, check the "internet usage policy" with your ISP

  • Still I get the same error after download completes – Sameera.San Jan 22 '18 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.