3

I'm not sure whether this is regarding a vim command or a screen command, although I think it's the latter.

I use vim under screen all the time, and every once in a while will hit a key combo that freezes the virtual terminal I'm using.

I can see everything, and I can still issue screen commands on that terminal, but I can't perform any actions within the terminal itself. I can create/flip to other virtual terminals and they all work nicely.

I've no idea what I'm doing to lock up one particular terminal.

Also, searching for answers online, CTRL-Q and CTRL-S are mentioned everywhere. Hitting CTRL-Q does nothing, and given the ambiguity of it, I tried both CTRL-q and CTRL-Q.

--edit--

One other detail is that I'm using a Macbook, but I ~think~ I've had the same problem using KDE/Mint on a PC.

1
  • Does pressing Ctrl-W in insert mode remove a word? Maybe Ctrl-Q doesn't work because of some terminal oddity? Did you try using Command instead of Ctrl?
    – NieDzejkob
    Jan 19 '18 at 15:51
6

These keys are used for XON/XOFF flow control. If flow control is activated then Ctrl-S stops the terminal output. The screen commands still work as they are not part of the controlled terminal.

Ctrl-Q activates the terminal output. Thus it does not make a difference if Ctrl-S has not been pressed before.

2

The accepted answer talks about flow control for the terminal you are running GNU Screen in. This would not result in the behaviour you are describing since you wouldn't be able to flip to and use your other Screen-terminals.

The behavior you are describing sounds like you turned flow control on within GNU Screen itself. If you hit Ctrl+A followed by S this will send XOFF to the current Screen-terminal, but will leave the other Screen-terminals you could switch to alone. To get things working again, simply hit Ctrl+A followed by Q in the terminal that you want to get moving again.

1
  • This actually seems to fit what I'm running into, ~especially~ when considering that I use a Dvorak keyboard layout in which the S and N keys are adjacent. I could easily see my self meaning to flip to the next virtual terminal and instead sending the XOFF to the active one. Dec 17 '19 at 17:18
0

The problem is :

frozen vim::

I have running KNOPPIX 8.6

I use the KDE desktop with 4 workspaces.

In workspace 2, 3 and 4 I have 4 Terminals konsole open.

In the total of 12 konsole windows, two vim version 8.3 are running at the same time. In one of these vim sessions, I am editing one of my bash scripts.

In the Ex cmd line I, very many times, am trying to use the vim search command / and, or the :s substitute command.

Each time this one vim is frozen for very many hours, thus it seems that I need to kill this vim. vim does not react or respond to any key.

With the mouse I can switch to another workspace, to another 'konsole'. The other vim and all other tasks do work.

Presumably the reason is:

In the pattern of the / command there are some ~ (tilde). Some are escaped by backslash, some are not escaped.

After some such vim-frozen events I have disabled the option incsearch.

Before: bringing the pattern into the cmd line causes frozen vim. After: executing command / causes frozen.

I suppose ~ causes recursive searching in an endless loop.

PROBLEM of vim:

CTRL-C does not work to stop the search activity.

There is no indicator that vim is working, is searching.

In vim help there is no item, no tag to address frozen, non-responding vim.

1
  • I cannot see, if you have received my text. Apr 25 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.