0

Suddenly this Centos 7.2/Plesk 12.5 dedicated server restarted and never booted again. most services fail. i don't have ssh so i can only go through rescue system (Debian) and check the logs. I didn't make any changes whatsoever for a long time but plesk keeps updating regularly.

As far as my search goes it seems that dbus fails and everything else follows. the whole things ends in a loop i thought it could be a hardware failure so i asked the guys in Hetzner and they did a full hardware test. Everything came clean

I pasted part of my "messages" log on an original post in SO Dedicated Centos 7.2/Plesk 12.5 server most services Fail on boot Any ideas?

thank you in advance

  • 1
    Can't find root? If you boot from some recovery media and mount the OS drive, can your /etc/passwd, /etc/shadow and /etc/group files OK? – Raman Sailopal Jan 18 '18 at 12:48
  • I booted rescue system, mounted md2. In /mnt/etc/ all 3 files exist. all 3 have one more file with dash like passwd-, shadow- etc. passwd file is empty. – JoePanpi Jan 18 '18 at 13:35
  • I suggest that there is your problem. Have you got a backup of your passwd file? – Raman Sailopal Jan 18 '18 at 13:40
  • is this the root pass ? i only have plesk backups, i don't think they include passwd file. – JoePanpi Jan 18 '18 at 13:42
  • oh my! i just opened a passwd file from another server. how did all this data got deleted? is this an attack? and you are so right! it is modified 1 minute before the problem started – JoePanpi Jan 18 '18 at 13:44
0

It seems as though the issue here is that pamd is having difficlty pasing the required authentication files i.e. /etc/passwd, /etc/shadow, /etc/group and hence cannot find a root user. Some of the file may be missing.

  • any suggestions why such things can happen? thanks again. – JoePanpi Jan 18 '18 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.