6

I am running a fresh install of centos 7 gnome so I could rdp from windows I followed the following instructions but when I connect I get an additional login that says

authentication is required to create a color profile

How do I remove this additional login?

In an attempt to solve this problem I tried a solution here but it did not work. because link is a lot more then just a solution to this problem I pasted the solution below.

When you login into your system via remote session, you will see this message popping up. You can simply cancel and you will be able to proceed till the next time you login and start a new session.

To avoid this prompt, we will need to change the polkit configuration. Using admin privileges, create a file called 02-allow-colord.conf under the following directory /etc/polkit-1/localauthority.conf.d/

The file should contains the following instructions and you should not be prompted anymore with such authentication request while remoting into your system

polkit.addRule(function(action, subject) { if ((action.id ==
“org.freedesktop.color-manager.create-device” || action.id ==
“org.freedesktop.color-manager.create-profile” || action.id ==
“org.freedesktop.color-manager.delete-device” || action.id ==
“org.freedesktop.color-manager.delete-profile” || action.id ==
“org.freedesktop.color-manager.modify-device” || action.id ==
“org.freedesktop.color-manager.modify-profile”) &&
subject.isInGroup(“{group}”)) { return polkit.Result.YES; } });
  • I have the same issue here, I'm running a centos7.5.1804. I'm using the xrdp, and if I select xvnc, I don't see this dialog, but if I select xorg, I do see the annoying dialog. – ollydbg23 Jul 26 '18 at 6:31
10

I found this bug and some workarounds here:

https://bugzilla.redhat.com/show_bug.cgi?id=1149893

More specific you have to place a .rules file in

/etc/polkit-1/rules.d/

(Select a filename and just givr the .rules extension)

and give the rules:

polkit.addRule(function(action, subject) {
   if ((action.id == "org.freedesktop.color-manager.create-device" ||
        action.id == "org.freedesktop.color-manager.create-profile" ||
        action.id == "org.freedesktop.color-manager.delete-device" ||
        action.id == "org.freedesktop.color-manager.delete-profile" ||
        action.id == "org.freedesktop.color-manager.modify-device" ||
        action.id == "org.freedesktop.color-manager.modify-profile") &&
       subject.isInGroup("ATTENTION")) {
      return polkit.Result.YES;
   }
});

Then you have to Replace the word "ATTENTION" with your user's group.

  • 1
    With the changes mentioned above, I can workaround this issue. Thanks. – ollydbg23 Jul 26 '18 at 6:52
  • 1
    Great answer; thanks for including the references. This worked for me on Fedora 28, connecting with VNC. – Dogweather Sep 11 '18 at 22:10
  • I have some upvotes these days and possibly some distribution needs a bug fix or something... I think that adding (once) your distribution that gives this error you will help to find out which distro needs a bug report to get fixed the sooner possible. (Not sure if this could be acceptable or suggested here, but thinking it could help. The linked bug was about fedora 23 and has already been closed as EOL. I think it would help to know what disto gives this error these days.) – koleygr Apr 11 at 20:44
  • I also had to restart polkit to load the new rule file (i.e. systemctl restart polkit). Rebooting should also work. – nochkin May 3 at 13:17
4

I had the same problem and found a different work-around here:

https://github.com/TurboVNC/turbovnc/issues/47#issuecomment-412005377

This variant is claimed to work independent of authentication scheme (e.g. LDAP).

Create /etc/polkit-1/localauthority/50-local.d/color.pkla (note: .pkla extension is required) with the following contents:

[Allow colord for all users]
Identity=unix-user:*
Action=org.freedesktop.color-manager.create-device;org.freedesktop.color-manager.create-profile;org.freedesktop.color-manager.delete-device;org.freedesktop.color-manager.delete-profile;org.freedesktop.color-manager.modify-device;org.freedesktop.color-manager.modify-profile
ResultAny=yes
ResultInactive=yes
ResultActive=yes

Worked for me.

  • Worked for me as well (Ubuntu 18.04). Accepted answer didn't work for me (perhaps I did something wrong). Hmm, perhaps I spoke/wrote too soon. Connection was soon dropped and when I reconnect it drops soon after connect. Remove the file and looks like I can connect again (but with the original issue). – ds00424 Feb 12 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.