11

I've recently reinstalled my workstation with Fedora 27, and since doing so, virt-manager has been doing one strange thing.

Every time I open a VM console and then move the mouse into the window, a dialog appears asking me:

Virtual Machine Manager wants to inhibit shortcuts

You can restore shortcuts by pressing Super+Escape.

virt-manager screenshot

It doesn't seem to matter whether I click Deny or Allow. In either case, pressing keys such as Ctrl+W are handled by virt-manager, rather than sent to the VM. In that case, for example, instead of deleting a word on the line I'm editing, the window closes.

Before reinstalling my machine, which was also on Fedora 27, I never saw this dialog box.

The only change I can recall making with respect to virt-manager is to add a PolicyKit rule to allow my user to manage system virtual machines without a password:

# cat /etc/polkit-1/rules.d/51-org.libvirt.unix.manage.rules 
polkit.addRule(function(action, subject) {
        if (action.id == "org.libvirt.unix.manage" &&
            subject.user == "error") {
                return polkit.Result.YES;
                polkit.log("action=" + action);
                polkit.log("subject=" + subject);
        }
});

These are the package versions I have now:

# rpm -q libvirt-daemon virt-manager
libvirt-daemon-3.7.0-3.fc27.x86_64
virt-manager-1.4.3-2.fc27.noarch

The other difference is that now I am on Wayland, whereas before I was using X. When I log in with "Gnome on Xorg", the problem goes away.

How do I prevent this useless dialog from appearing under Wayland, and have command keys such as Ctrl+W be sent to the VM rather than processed by virt-manager?

2
  • wayland is still under heavy development and there may not be a configuration tweak to solve this problem for you. your best bet for a solution may be to reproduce this with the latest versions, then file a bug with your wayland compositor and/or virt-manager.
    – quixotic
    Commented Jan 20, 2018 at 22:17
  • same here! askubuntu.com/questions/1000207/… Commented Jan 26, 2018 at 23:08

2 Answers 2

1

You should upgrade/reinstall your workstation with Fedora 30. The improvements to Wayland in the latest release have fixed that issue.

https://bugzilla.redhat.com/show_bug.cgi?id=1668036

https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/382

1
  • Looks like that will fix the problem. I am still curious why this prompt even exists in the first place, though. It seems rather useless. Commented Sep 12, 2019 at 17:03
0

This is an additional option to resolve this challenge. In addition to John Call's good answer above.

If you use Wayland with GNOME, but somehow you can not yet upgrade your Wayland to the latest stable version, a quick and easy temporary workaround is to install this GNOME Extension at https://extensions.gnome.org/extension/1619/quiet-shortcuts/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .