1

I am working on a Linux mint machine in my office. There are two internet connections. We often switch the connection due to the error in one connection. But once the switching is done, I need to restart my machine to reconnect it to the internet.

My distribution is: Linux Mint 4.4.0-108-generic

I tried to disable and enable the connection, and run the commands

sudo /etc/init.d/networking restart

sudo service networking restart

But one of them doesn't seems working. I still need to restart the machine.

But I couldn't find the issue with others. Only me using mint. Others are using ubuntu.

Is there any solution for this?

  • 1
    Does it work if you do instead sudo service networking stop and sudo service networking start? – Rui F Ribeiro Jan 16 '18 at 9:40
  • @RuiFRibeiro, I never tried that sequence. But I tried the same from the GUI. Hope both are same. But it still didn't make any change. – Arun Jan 16 '18 at 9:42
  • Hoping is not enough. Try it then; I do remember vaguely a bug/issue of this working when restart does not work. – Rui F Ribeiro Jan 16 '18 at 9:43
  • @RuiFRibeiro, Thanks for the info. Let me check on the next time – Arun Jan 16 '18 at 9:45
  • Also, you can post the output of ifconfig before and after. – Kevin Lemaire Jan 16 '18 at 10:27
0

Try the following command to restart the network manager. sudo service network-manager restart

This worked for me.Hope it works for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.