1

My problem is the mouse pointer speed is too high, and the GUI adjustments have no effect. I found suggestions on using xinput to fix this. Here's what I found:

nate@Cortana-Mint ~ $ xinput --list --short
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ USB OPTICAL MOUSE                         id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳   USB Keyboard                            id=9    [slave  keyboard (3)]
    ↳   USB Keyboard                            id=10   [slave  keyboard (3)]
    ↳ gspca_zc3xx                               id=11   [slave  keyboard (3)]
nate@Cortana-Mint ~ $ xinput --list-props 12
Device 'USB OPTICAL MOUSE':
    Device Enabled (133):   1
    Coordinate Transformation Matrix (135): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (269): 0.000000
    libinput Accel Speed Default (270): 0.000000
    libinput Accel Profiles Available (271):    1, 1
    libinput Accel Profile Enabled (272):   1, 0
    libinput Accel Profile Enabled Default (273):   1, 0
    libinput Natural Scrolling Enabled (274):   0
    libinput Natural Scrolling Enabled Default (275):   0
    libinput Send Events Modes Available (253): 1, 0
    libinput Send Events Mode Enabled (254):    0, 0
    libinput Send Events Mode Enabled Default (255):    0, 0
    libinput Left Handed Enabled (276): 0
    libinput Left Handed Enabled Default (277): 0
    libinput Scroll Methods Available (278):    0, 0, 1
    libinput Scroll Method Enabled (279):   0, 0, 0
    libinput Scroll Method Enabled Default (280):   0, 0, 0
    libinput Button Scrolling Button (281): 2
    libinput Button Scrolling Button Default (282): 274
    libinput Middle Emulation Enabled (283):    1
    libinput Middle Emulation Enabled Default (284):    0
    Device Node (256):  "/dev/input/event4"
    Device Product ID (257):    2362, 9505
    libinput Drag Lock Buttons (285):   <no items>
    libinput Horizonal Scroll Enabled (258):    1

As you can see, I don't have the velocity scaling and deceleration properties, which is apparently what I'm supposed to set. "Accel Speed" is already at 0, so not sure what I could do there. I tried setting the acceleration via xset but that didn't seem to have any effect either. I searched for info on updating mouse drivers in case that's the problem but didn't find much other than reinstalling xorg, which doesn't sound like what I want. Any suggestions?

2

I had this problem as well. You can try setting it with the xinput command. Like:

xinput --set-prop 12 269 -0.5

Where the 12 is the mouse id, 269 is the code for "libinput Accel Speed", and the -0.5 is telling it to go slower (I guess 0 is the baseline, so to slow it, you go below 0). If that's still too fast, you can try -0.6, -0.7, etc. To reset it, set it back to 0.0.

  • Thanks, I haven't been using Linux lately - also have gotten a new mouse. – nasch Feb 25 '18 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.