for a couple of days I cannot upgrade my Arch system after I run sudo pacman -Syu I'm receiving this error:

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: libquicktime: installing libx264 (2:152.20171224-1.0) breaks dependency 'libx264.so=148-32'

If I run sudo pacman -S libx264 I get this:

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: ffmpeg: installing libx264 (2:152.20171224-1.0) breaks dependency 'libx264.so=148-32'
:: ffmpeg2.8: installing libx264 (2:152.20171224-1.0) breaks dependency 'libx264.so=148-32'
:: libquicktime: installing libx264 (2:152.20171224-1.0) breaks dependency 'libx264.so=148-32'


Finally I managed to perform an upgrade by putting libx264 on hold as stated on my comment below but still cannot get it why even --force option won't overwrite this package.

  • try running -Syyu instead of -Syu to make sure your package db is up-to-date. – quixotic Jan 15 '18 at 21:46
  • -Syyu ends up with the same results as -Syu – JoKeR Jan 15 '18 at 21:53
  • are you on amd64 or another architecture? have you tried a different mirror? – quixotic Jan 15 '18 at 21:59
  • no I'm still running i686 using archlinux32 repos which are still maintained – JoKeR Jan 15 '18 at 22:11
  • well I happened to partially upgrade what I did I ignored libx264 package in pacman.conf and upgrade finally moved forward and after that I've noticed that libx264 conflicts with libx264-10bit that's the one that wants to replace libx264 I assume, I even tried to reinstall it with --force option but it still won't go. – JoKeR Jan 15 '18 at 22:48

I managed to fix this by simply removing ffmpeg0.10:

yaourt -R ffmpeg0.10

(no complaints from the system doing that). After that a complete upgrade with

sudo pacman -Syyu

worked just fine.

  • thanks for the answer but the issue has gone on its own since today probably the issue was on Arch side – JoKeR Jan 17 '18 at 17:10

It's been some time since I posted this question but anyways I found another solution with pacman

sudo pacman -Rdd libx264

sudo pacman -S libx264


sudo pacman -S libx265

Depends on what you need and then:

sudo pacman -Syyu

To complete full upgrade.

Basically works with any package that gets stuck.

  • Nice. To clarify: -Rdd performs a remove skipping all dependency checks. And then you just reinstall it to get the newer version. – ericx Aug 3 '18 at 15:13

Mb uninstall your AUR packages so you can properly upgrade. Or build using aurutils as it mb uses clean chroot builds. After that also try:

pacman -Syu libx264


pacman -Syyu libx264 # Passing two --refresh or -y flags will force a refresh of all package lists even if they appear to be up to date.

This could mean that your AUR packages need an update

  • funny thing that I did upgrade all the packahes only libx264 won't upgrade I stated what I did in a comment above – JoKeR Jan 15 '18 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.