0

I have an fstab mountpoint defined as follows:

//host.local /media/share1 cifs noexec,nofail,auto,nouser,_netdev,credentials=/home/foo/.smbcredentials,gid=1000,uid=1000,rw 0 0

The network share is available on local NAS server (QNAP) configured to suspend disk storage within 15 minutes of inactivity. That is working as intended when using nautilus to browse samba share. However, when mounting with cifs the client is periodically querying NAS with what seems an empty request "Command: Create (5)" or Keep-Alive "Command: KeepAlive (13)". The NAS responds with "STATUS_SUCCESS -> Create Action: The file existed and was opened (1)" or Keep-Alive response.

SMB2 (Server Message Block Protocol version 2)
SMB2 Header
    Server Component: SMB2
    Header Length: 64
    Credit Charge: 1
    Channel Sequence: 0
    Reserved: 0000
    Command: Create (5)
    Credits requested: 2
    Flags: 0x00000000
    Chain Offset: 0x00000000
    Message ID: Unknown (299)
    Process Id: 0x00000ba6
    Tree Id: 0x79c61208
    Session Id: 0x00000000448e3aa5
    Signature: 00000000000000000000000000000000
    [Response in: 1748]
Create Request (0x05)
    StructureSize: 0x0039
        0000 0000 0011 100. = Fixed Part Length: 28
        .... .... .... ...1 = Dynamic Part: True
    Oplock: No oplock (0x00)
    Impersonation level: Impersonation (2)
    Create Flags: 0x0000000000000000
    Reserved: 0000000000000000
    Access Mask: 0x00000080
    File Attributes: 0x00000000
    Share Access: 0x00000007, Read, Write, Delete
    Disposition: Open (if file exists open it, else fail) (1)
    Create Options: 0x00000000
    Filename: 
        Offset: 0x00000078
        Length: 0
    ExtraInfo: NO DATA
        Offset: 0x00000000
        Length: 0

Can I somehow make cifs to not periodically ping NAS share so the NAS can go into standby eventually? Otherwise the NAS is constantly active, noisy and possibly overheating.

0

This is not CIFS issue, this is just an application case. I'm not an expert with this app but i think that it maybe a "keep alive" operation.

Dig into it.

  • From what I've captured over the network the client is sending periodical Keep-Alive requests to SMB server. > Command: KeepAlive (13) – Tez Jan 18 '18 at 22:34
  • That is what I thought, look in the config file and try to find the "keep-alive" flag, if there is any. – Eliad Cohen Jan 19 '18 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.