2

I have problem with video driver. I have

  • Processor: Intel Core i7-8700K CPU @ 3.70 GHz x 6

  • Graphics Card: Intel Corporation Device 3e92 (prog-if 00 [VGA controller])

And current Debian Buster distro.

# uname -a
Linux tanya 4.14.0-2-amd64 #1 SMP Debian 4.14.7-1 (2017-12-22) x86_64 GNU/Linux

Here /var/log/Xorg.0.log:

[    10.481] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    10.481] (II) FBDEV: driver for framebuffer: fbdev
[    10.482] (II) VESA: driver for VESA chipsets: vesa
[    10.485] (EE) open /dev/dri/card0: No such file or directory
[    10.485] (WW) Falling back to old probe method for modesetting
[    10.485] (EE) open /dev/dri/card0: No such file or directory

and lines:

[    10.486] (**) FBDEV(1): claimed PCI slot 0@0:2:0
[    10.486] (II) FBDEV(1): using default device
[    10.486] (WW) Falling back to old probe method for vesa
[    10.486] (EE) Screen 0 deleted because of no matching config section.

And this

# grep EE /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    10.485] (EE) open /dev/dri/card0: No such file or directory
[    10.485] (EE) open /dev/dri/card0: No such file or directory
[    10.486] (EE) Screen 0 deleted because of no matching config section.
[    10.494] (EE) AIGLX: reverting to software rendering

I have not xorg-file, I tryed install linux-image-amd64 firmware-misc-nonfree packages from contrib non-free repository buster, but it didn't help.

/var/log/kern.log (i915 keyword, time prefix removed):

[drm] The driver support for your hardware in this kernel version is alpha quality
See CONFIG_DRM_I915_ALPHA_SUPPORT or i915.alpha_support module parameter
to enable support in this kernel version, or check for kernel updates.
...
snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)
...
snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec
snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec

Any help would be appreciated.

Thank you!

3

Kernels 4.13 and 4.14 have support for Coffee Lake, but as an alpha, so you need to boot the kernel with

i915.alpha_support=1

You can do this by editing the kernel command line manually during the boot, or by editing /etc/default/grub’s GRUB_CMDLINE_LINUX_DEFAULT. In the latter case, run update-grub before rebooting...

This won’t be necessary with kernel 4.15 which enables Coffee Lake support by default.

  • I guess the developers considered it potentially dangerous (because it wasn’t tested as well as they’d like, perhaps), so they wanted to avoid it being enabled by default... Without support, you could still boot to a text console, whereas with buggy support, you might not be able to boot at all. – Stephen Kitt Feb 24 '18 at 10:14
  • I confirm this now worked for me, with Ubuntu 16.04 and an i7 8th gen. Also solves the screen remaining blank after a system suspend. For a slightly finer elucidation of the process may I recommend people also follow askubuntu.com/a/1002662/208696. Thanks a lot for this answer!!! – Matan Feb 24 '18 at 10:22
  • This doesn't work for me on Debian 9 with Kernel 4.14 from Stretch-backports. Any idea? – Simon Mar 22 '18 at 13:43
  • @Simon could you clarify what you mean by “doesn’t work”? – Stephen Kitt Mar 22 '18 at 13:52
  • I meant that 3D acceleration does not work with Debian 9, Kernel 4.14 and i915.alpha_support=1 kernel parameter. i3 8100 cpu. Everything else does work. Sorry for not being precise. – Simon Mar 27 '18 at 5:50
0

I had the same problem. Even extended desktop didn't work. Only the dual monitors but with clone were working.

Now my dual monitors works with extended desktop with good resolution 1920x1080 each.

I have:

  • Processor: Intel Core i5-8400 CPU @ 2.80GHz
  • Graphics Card: Intel Corporation Device 3e92
  • Motherboard: Gigabyte Z370 HD3

My solution was:

  • Reinstall my PC with Debian Stretch, selecting the whole packages for gnome and kde during installation so they installed all necessary graphic packages and drivers.

  • After installation finished I added backports for that version to /etc/apt/sources.list: deb http://ftp.de.debian.org/debian stretch-backports main

  • Then installed Kernel 4.18 apt-get install linux-image-4.18.0-0.bpo.1-amd64

  • Rebooted and voila!! my monitors worked with good resolution and extended desktop using kde.

Looks like for Kernel 4.18 is not necessary add any parameter to kernel boot or grub. It will enable Coffee Lake support by default.

I hope this works for you. I was struggling with this problem for a couple of days ;).

Cesar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.