2

My battery information has been disappearing and reappearing for about a month now. I thought maybe I missed some important package with my custom build so I recently reinstalled Manjora i3 (partly in hopes of fixing this problem) and this morning my i3status states "No battery." I checked for updates and there were quite a few. I restarted the laptop after I ran those updates. Still no battery staus.

[3953(sir)/home/sir] upower -e                                                
/org/freedesktop/UPower/devices/line_power_ADP1
/org/freedesktop/UPower/devices/DisplayDevice
[3953(sir)/home/sir] upower -i /org/freedesktop/UPower/devices/line_power_ADP1
  native-path:          ADP1
  power supply:         yes
  updated:              Sun 14 Jan 2018 03:54:37 PM EST (1107 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    warning-level:       none
    online:              no
    icon-name:          'ac-adapter-symbolic'

[3953(sir)/home/sir] upower -i /org/freedesktop/UPower/devices/DisplayDevice  
  power supply:         no
  updated:              Sun 14 Jan 2018 03:54:37 PM EST (1112 seconds ago)
  has history:          no
  has statistics:       no
  unknown
    warning-level:       none
    icon-name:          'battery-missing-symbolic'

[3953(sir)/home/sir] acpi
[3953(sir)/home/sir] screenfetch

 ██████████████████  ████████     sir@3953
 ██████████████████  ████████     OS: Manjaro 17.1.1 Hakoila
 ██████████████████  ████████     Kernel: x86_64 Linux 4.9.68-1-rt60-MANJARO
 ██████████████████  ████████     Uptime: 26m
 ████████            ████████     Packages: 917
 ████████  ████████  ████████     Shell: zsh 5.4.2
 ████████  ████████  ████████     Resolution: 1280x800
 ████████  ████████  ████████     WM: i3
 ████████  ████████  ████████     GTK Theme: Adapta-Nokto-Eta-Maia [GTK2/3]
 ████████  ████████  ████████     Icon Theme: Vibrancy-Full-Dark-Teal
 ████████  ████████  ████████     Font: Fantasque Sans Mono 10
 ████████  ████████  ████████     CPU: Intel Core i5-2415M @ 4x 2.9GHz [69.0°C]
 ████████  ████████  ████████     GPU: Mesa DRI Intel(R) Sandybridge Mobile 
 ████████  ████████  ████████     RAM: 709MiB / 7899MiB

I am on an MacBook Pro, 13-inch, early 2011. I don't know if acpid.service or upower.service have anything to do with i3status being unable to find my battery, but they have both been enabled and started (acpi.service shows as inactive).

Edit: For what it's worth, I am dual-booting macOS on this same machine, no problems with finding or reading the battery on High Sierra.

Edit: Also, it appears that xfce4-power-manager has stopped working. The laptop no longer suspends when the lid is closed. And if I run systemd suspend the system is only suspended for about 4 seconds, then everything wakes back up. I'm guessing these two are related (if not I can remove this create a new question).

Edit: I booted up SparkyLinux, a Debian based distro, using a liveCD, and acpi returned the expected information.

$ acpi -i
Battery 0: Full, 97%
Battery 0: design capacity 5770 mAH, last full capacity 5031 mAH=87%
$ acpi -b
Battery 0: Discharging, 95%, 03:54:47 remaining.

I booted into ArchLabs, and acpi pulled all of the same information as it did on Sparky, only it listed the discharging time as 4+ hours. I booted back into Manjaro and i3status still reads "No battery."

Edit: Clarification of my question: Where is my battery's information and how do I get my Manjora i3 (via i3status or acpi) to locate and display said information?

3
  • @RuiFRibeiro It is the original battery, according to the light on the side of the laptop it's charging and holding it like usual. – 345422 Jan 14 '18 at 22:40
  • The light does not account for the health of the battery. – Rui F Ribeiro Jan 15 '18 at 8:39
  • Is your battery indicator looking for the battery in the correct place? I had a similar issue with the battery indicator on AwesomeWM. It was looking for bat1, and the battery was at bat0, so it just defaulted to 'no battery'. Check your configuration files. – Mio Rin May 11 '18 at 16:58
0

I would try to get the statistics of that battery, even if having to boot from an external hard drive with OS/X.

From the top of my head, the average life of your battery is between 2 and 5 years.

Most likely, being the original one, at 7 years old, your battery is not working well anymore and is dying: thus disappearing and closing the lid not working anymore.

We had a batch of Macs of your model at work (from early 2011), and all of them had to have the battery replaced around 2 years go.

BTW Apple does not have replacements anymore, we had to buy a clone from a grey brand. iFixit.com has probably clones for that.

4
  • I don't believe the battery is dead yet, because my battery has not been charging or discharging any faster or differently. I'm guessing, if this is the case, it should be persistent across builds, so I booted the computer from the Manjaro Architect USB (that I used to install it), acpi still returns nothing. I booted from a Sparky Linux USB I have, Debian based, acpi returns Battery 0: Full, 98%. – 345422 Jan 15 '18 at 13:02
  • Let´s not put it dead, but had better days. 98% means nothing, how long does it last? Better yet, try do get the stats. – Rui F Ribeiro Jan 15 '18 at 13:49
  • I'll test that when I get home today. But my question is not how healthy is the battery; my question is how do I get the battery and percent to appear in my i3status. Which stats do you want me get? – 345422 Jan 15 '18 at 16:18
  • No ideia how to do it on the Linux side. It is a smart battery, Mac OS has stats about the number of cycles, and how healthy it is. – Rui F Ribeiro Jan 15 '18 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.