2

I'm trying to remove this dkms module but am running into trouble.

I run

sudo dkms uninstall rtl8812au/4.3.14

and I get

Error! The module/version combo: rtl8812au-4.3.14
is not located in the DKMS tree.

However, when I run dkms status, I get

8188eu, 1.0, 4.13.0-26-generic, x86_64: installed
bcmwl, 6.30.223.271+bdcom, 4.13.0-26-generic, x86_64: installed
mt7610u_sta, 1.0, 4.13.0-26-generic, x86_64: installed (WARNING! Diff between built and installed module!)
rtl8812au, 4.3.8.12175.20140902+dfsg: added

and when I go into the Makefile.dkms in the following folder,

y9@y9-aspire:~/rtl8812AU_8821AU_linux$ ls
clean            core       ifcfg-wlan0  Makefile       README.md
contrib          dkms.conf  include      Makefile.dkms  runwpa
CONTRIBUTORS.md  fetch.sh   Kconfig      os_dep         wlan0dhcp
contributors.sh  hal        LICENSE      platform

I see

modname := rtl8812au
DKMS := dkms
modver := 4.3.14

I just want to know how I can clear my dkms modules. Thank you.

  • Is it solved already? – Rui F Ribeiro Jan 13 '18 at 22:27
  • 1
    Yeah I think I fixed it. – Glassjawed Jan 13 '18 at 22:38
  • Mark it as solved, if it was not my answer, write your own. – Rui F Ribeiro Jan 13 '18 at 22:39
4

In case of normal operations gone wrong, you can always delete dkms add-ons by hand, with sudo or as root.

Normally the modules sources are installed by make install under /var/lib/dkms/ in a directory with the corresponding name, probably named rtl...something. Just delete that directory.

You have also to delete the corresponding compiled file module under /lib/modules/KERNEL_VERSION/updates/dkms/ where KERNEL_VERSION is your current kernel. The file should be called rtl...something.ko or similar.

Once done that, you can either try to rmmod the module or falling that, reboot.

No module and corresponding dkms anymore in the system.

While not critical, the module dependencies also need to be updated after deleting the module. Run:

sudo /sbin/depmod -a 
  • After doing all that, is sill get with modinfo rtl8812au: filename: /lib/modules/4.13.0-32-generic/updates/dkms/rtl8812au.ko modinfo: ERROR: could not get modinfo from 'rtl8812au': No such file or directory. Where does it get the filename from? Is there anything else i still need to clean up? – Alexey Feb 17 '18 at 18:34
  • @Alexey updated the answer, should solve your question. – Rui F Ribeiro Feb 17 '18 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.