0

Trying to boot Ubuntu 16.04 from GRUB but it ends up in Emergency mode and Control-D doesn't load the system.

This is most probably is caused by nvidia drivers:

nouveau 0000:01:00.0: priv: HUB0: 6013d4 ...
nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ...

enter image description here

After adding a boot option nouveau.modeset=0 at the end of the linux line, these two messages disappear but the problem still remians -- cannot boot the Ubuntu. enter image description here

In addition if I go to recovery mode I cannot enable network there to update drivers, for example.

closed as unclear what you're asking by Jeff Schaller, jimmij, Rui F Ribeiro, sebasth, maulinglawns Jan 14 '18 at 17:40

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Did you look at the output of journalctl -xb as suggested in the screenshot? We will need that information. – guntbert Jan 13 '18 at 19:39
  • 1
    systemctl --failed is another starting point, to simply name failed unit(s). Emergency mode should only be triggered by being unable to mount a filesystem (e.g. var.mount unit), so I don't expect it is due to nvidia. – sourcejedi Jan 13 '18 at 19:52
  • sadly the text of mount errors has never been logged in the journal, due to an oversight which I submitted a patch for today :-(. So another useful starting point is mount -a, to try and get error messages. – sourcejedi Jan 13 '18 at 19:59
  • Does the partition mount if you boot from a live-cd ? it will determinate if yes or no it is a mount issue or not – francois P Jan 13 '18 at 20:01
  • 1
    Thank you for your comments that helped me to find the answer. – Fibo Kowalsky Jan 14 '18 at 11:36
3

As @sourcejedi commented I tried systemctl --failed and got the following:

 UNIT                  LOAD   ACTIVE SUB    DESCRIPTION 
* media-win-Data.mount loaded failed failed /media/win/Data
* media-win-Misc.mount loaded failed failed /media/win/Misc

Which are Windows drives (without OS installed on them). After running mount -a I got the message that /dev/sda7 and /dev/sda5 cannot be mounted because:

The NTFS partition is in an unsafe state. Please resume and shutdown windows fully (no hibernation or fast restarting)

I turned off fast startup (recommended) in Windows 10 according to Unable to mount Windows (NTFS) filesystem due to hibernation. After shutting down Windows, Ubuntu boots without complaints.

Interestingly, I was using fast startup option for shutting down Windows for more than a month and Ubuntu has not complained about it before. That's why I didn't think that this could be the reason.

Not the answer you're looking for? Browse other questions tagged or ask your own question.