3

I would like to create a Debian sid chroot from my Arch Linux system. I have installed debootstrap from the community repository with pacman. Then I ran:

# debootstrap sid $MY_CHROOT http://debian.mirror.digitalpacific.com.au/debian/

based on the Debian Wiki article on this matter. Then what I got was almost an immediate (~5 seconds) exiting of the command with the output:

W: Cannot check Release signature; keyring file not available /usr/share/keyrings/debian-archive-keyring.gpg
I: Retrieving InRelease

To me this seems to indicate that debootstrap failed and did very little. On the off chance this warning was the cause of the subsequent error I ran the command again with the option --no-check-gpg and yet again it failed with the same output, except without the W: Cannot... line. Based on this Arch Linux forum thread I installed debian-archive-keyring with pacman. Then I re-ran the original debootstrap command and it returned:

I: Retrieving InRelease 
I: Checking Release signature
I: Valid Release signature (key id 126C0D24BD8A2942CC7DF8AC7638D0442B90D010)

and exited within 5 seconds again. As expected running with --no-check-gpg did nothing but silence the signature messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.