0

I have the following /etc/fstab entry which fails to execute at system boot/startup:

/dev/sdb1   /media/ssd256   ext4    rw,user,exec,umask=000 0 0

Doing

sudo mount -a

yields:

mount: /media/ssd256: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.

However, if I sudo gparted and mount via its UI, then the device is mounted. I am not sure how to fix this issue.

EDIT: I changed the options to use defaults instead of rw,user,exec,umask=000, now sudo mount -a also works. The question now is: what is wrong with my initial options?

  • 2
    Does gparted actually show an ext4 filesystem type for this device? What output for fsck command on /dev/sdb1? What if you replace options rw,user,exec,umask=000 with just "defaults"? – tonioc Jan 13 '18 at 8:30
  • Did you fsck /dev/sdb1 ? – Mukesh Sai Kumar Jan 13 '18 at 8:33
2

This is why...

dmesg | tail will show:

EXT4-fs (dm-4): Unrecognized mount option "umask=000" or missing value

Indeed, the umask option is not part of the accepted options for the ext4 file system : see man mount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.