2

So, ever since I switched to xfce, I have been having some issues with suspending my system.

My system wakes from sleep normally most of the time, but every once in a while, my computer will turn on, and my status lights will turn on, but my screen won't initiate. I really have no idea why this happens, and it's been bothering me for too long.

I have a sneaking suspicion it has to do with xscreensaver. This is because I have disabled it, but I managed to wake my computer immediately one time and was greeted both to the lightdm login screen, then afterwards the xscreensaver login, which shouldn't be there.

  • I have similar problem. As a workaround, I press Ctrl+Alt+F1 then Ctrl+Alt+F7. After this, X11 session will be reactivated in a few seconds. – Dávid Horváth Sep 2 '19 at 14:02
  • @DávidHorváth ah, you posted this right after it started happening again. I guess its another bug? Ill try that next time. – SpecialBomb Sep 2 '19 at 18:48
1

Removing light-locker and using lightdm solved the problem for me on Debian 10.

$ sudo apt install lightdm
$ sudo apt remove light-locker

On Thinkpad T410.

| improve this answer | |
  • I remove my previous comments, [see in history]. Installing either xscreensaver or xfce4-screensaver instead of light-locker not solve this problem. I think something is wrong in lightdm when want to turn on monitor. This solution completely disable any way of lock monitor. – EsmaeelE Mar 26 at 5:29
0

Some kernel version have problems waking from a deep-sleep. Go into your BIOS and search for "C States" or "Sleep states" or similar. Change the maximum value to 1, or even to off, and see if that removes the problem. These "C States" are used to moderate the CPU power consumption, so you want to allow the highest-value state that your kernel will wake up from.

| improve this answer | |
  • alright, ill look at that. It will take a bit to test it, as the chance that my computer will wake properly is seemingly random. – SpecialBomb Jan 16 '18 at 0:01
  • That didn't seem to work. I only had full power mode and ram power only mode, and I still had issues with either one of them. – SpecialBomb Jan 17 '18 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.