So, ever since I switched to xfce, I have been having some issues with suspending my system.

My system wakes from sleep normally most of the time, but every once in a while, my computer will turn on, and my status lights will turn on, but my screen won't initiate. I really have no idea why this happens, and it's been bothering me for too long.

I have a sneaking suspicion it has to do with xscreensaver. This is because I have disabled it, but I managed to wake my computer immediately one time and was greeted both to the lightdm login screen, then afterwards the xscreensaver login, which shouldn't be there.

  • 1
    I have similar problem. As a workaround, I press Ctrl+Alt+F1 then Ctrl+Alt+F7. After this, X11 session will be reactivated in a few seconds. Sep 2, 2019 at 14:02
  • @DávidHorváth ah, you posted this right after it started happening again. I guess its another bug? Ill try that next time. Sep 2, 2019 at 18:48

3 Answers 3


Removing light-locker and using lightdm solved the problem for me on Debian 10.

$ sudo apt install lightdm
$ sudo apt remove light-locker

On Thinkpad T410.

  • I remove my previous comments, [see in history]. Installing either xscreensaver or xfce4-screensaver instead of light-locker not solve this problem. I think something is wrong in lightdm when want to turn on monitor. This solution completely disable any way of lock monitor.
    – EsmaeelE
    Mar 26, 2020 at 5:29
  • @vp1147 It FIXED the bug/issue. Thanks!!!
    – Allexj
    Sep 18, 2021 at 12:48

If restarting LightDM after switching+log-in in the text console helps, then you can try this solution, found originally here: In the VT1 console, you can write this 1-line script:

while true; do DISPLAY=:0 xrandr --auto && break || sleep 1s; done

It will start looping. Then you switch to the GUI console (Ctl-Alt-F7), and in 1 second it should become active, with login prompt. If this works, we can create a fully automatic solution.

  • This worked for me on Devuan Beowulf (corresponding to Debian 10) running the default graphical stack (xfce4). I will now do a recoverXsession script to run in another VT when it gets stuck after sleeping for long. Thanks!
    – 7heo.tk
    Oct 8, 2021 at 8:06

Some kernel version have problems waking from a deep-sleep. Go into your BIOS and search for "C States" or "Sleep states" or similar. Change the maximum value to 1, or even to off, and see if that removes the problem. These "C States" are used to moderate the CPU power consumption, so you want to allow the highest-value state that your kernel will wake up from.

  • alright, ill look at that. It will take a bit to test it, as the chance that my computer will wake properly is seemingly random. Jan 16, 2018 at 0:01
  • That didn't seem to work. I only had full power mode and ram power only mode, and I still had issues with either one of them. Jan 17, 2018 at 18:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .