22

I have installed Ubuntu 17.10 on my notebook. However, I cannot connect to wi-fi because there is a "No Wi-Fi Adapter Found" message.

I don't have any idea what to do next.

  • My notebook : Asus X555LN-XX507H
  • Network Adapter : Broadcom 802.11n BCM43142 (14e4:4365)

(This is a follow-on from my earlier post, https://unix.stackexchange.com/questions/415639/kali-linux-no-wifi-adapter-found, where I was advised to try an easier system than Kali.)

  • 1
    Which version of Ubuntu are you using? What is the output from lspci or lsusb that defines the network adapter? (Both of these need to be added to your question.) – roaima Jan 10 '18 at 19:15
  • Im using Ubuntu 17.10 I will add output from lspci and lsusb when I will have time – greed Jan 10 '18 at 19:49
  • Welcome to U&L , please update with the output of lspci -knn | grep Net -A3 – GAD3R Jan 11 '18 at 10:30
  • 1
    Does it output different line than BCM43142 (14e4:4365) ? – greed Jan 11 '18 at 19:23
36

Just connect using usb cable to do usb tethering, open terminal by Ctrl+Alt+T and type:

sudo apt-get install --reinstall bcmwl-kernel-source

Then, reboot.

| improve this answer | |
  • 2
    This didn't work for me in my ubuntu 17.10. I also tried to disable the secure boot in my bios but didn't have luck. As of now only ethernet cable works for me but when I try to use wifi connection I can't – Jaaayz Aug 26 '18 at 14:53
  • 1
    On a fresh install you might need to run sudo apt update before trying to install anything. – ubershmekel Nov 14 '18 at 8:46
  • A simple solution is here: unix.stackexchange.com/a/507631/189124 – Manohar Reddy Poreddy Mar 21 '19 at 8:20
  • I joined just to upvote, as this solved my issue, but I´d appreciate if you could give a bit more of insight on why that solved the issue – Chococroc Dec 14 '19 at 22:05
  • this worked for me in Lenovo G550 – Divyesh Prajapati Apr 17 at 15:19
10

So, the issue for me was because of secure-boot, uefi and the restriction on third party libraries which would be usually required for the network devices to work.

Following Rajat's comment proved useful for me on Ubuntu 18.04

sudo apt-get install --reinstall bcmwl-kernel-source

Reboot your OS and then follow instructions about Enrolling MUC. Once that is done, third party libraries should be able to interact with your devices and everything should work.

| improve this answer | |
  • 1
    hi, I have been stuck on this issue for 2 days. please share how do you Enrolling MUC. thanks~! – Franva Sep 16 '19 at 13:00
  • hi this doesnt work for ubuntu 18.04 – Ran Fang Apr 2 at 10:49
7

A problem with Broadcom BCM43142 (14e4:4365). the problem has been known for a long time. You need to download and install the package bcmwl-kernel-source

Source: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

| improve this answer | |
5

First, you'll need to find the exact model of the Broadcom network adapter chip your notebook has. "802.11n" is just the name of the Wi-Fi standard it supports: Broadcom has several wireless chips supporting that standard.

lspci -nn would be a good command to list all PCI(e) devices on your laptop and their PCI ID numbers: those numbers would allow a more accurate identification. lsusb will do the same for USB devices.

The lspci -nn listing line might look something like this:

12:00.0 Network controller [0280]: Broadcom Limited BCM43228 802.11a/b/g/n [14e4:4359]

Here, the numbers [14e4:4359] are the Device ID. The first part specifies the vendor (Broadcom = 14e4) and the second part identifies the device model.

The lsusb listing is a bit different, but the Device ID number is similar: 4 hexadecimal digits for the vendor id, a colon, and then 4 hexadecimal digits for the product ID.

You can check here for the Linux support status of various Broadcom chip models: https://wireless.wiki.kernel.org/en/users/drivers/brcm80211

Note that the supported Broadcom chips will need firmware: it is probably available pre-packaged in Ubuntu. If Ubuntu uses the same naming scheme as Debian, the firmware package name should be firmware-brcm80211.

With a bit of luck, installing this firmware package and rebooting might be enough to get your Wi-Fi functional if the necessary driver is already in kernel.

| improve this answer | |
  • BCM43142 14e4:4365 but there is nothing like that on the site. – greed Jan 10 '18 at 23:48
2

Installed Ubuntu 18.04 on an old Dell computer and got the same message (no wifi adapter found) when trying to connect to the internet. Tried some of the solutions proposed here and in other postings, none of which worked. Decided to re-install. During the installation there is a radial button "Install third party software for graphics and wi-fi hardware and additional media formats". The default is that this is not checked and so this option is not included in the default install. On the re-install, I checked this button, and after all the dust settled had no trouble connecting to the internet.

| improve this answer | |
  • This worked for me -- circa 2008 macbook installing Ubuntu 18.04 !! Select "Install third party software for graphics and wi-fi hardware and additional media formats" during install. Nice - thanks! – powderflask Jan 3 '19 at 4:18
2

This may be covered in other answers, still: Post UBUNTU installation and ethernet connected; 2 steps:

  1. run (sudo apt-get install firmware-b43-installer) -- reboot
  2. run (sudo apt-get install --reinstall bcmwl-kernel-source) -- reboot

Context: The drivers are proprietary components of BroadComm. Ubuntu (a non proprietary) will not be able to install the packages due to authentication failure even though they are downloaded. Hence the separate steps are to be followed to get wifi enabled. This does not get you bluetooth though. It may need another set of steps.

LINKS : https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx and previous answers.

If ethernet is not connected, download package from other machines, copy to UBUNTU machine and run.

Thanks to perror, Rajat, GAD3R and Alex.

| improve this answer | |
2

This is not a Ubuntu issue.
This is not any driver issue.
This is caused by me (and possibly you).

While watching some video... I tried to increase volume with:
Fn + F10 key combination ... But I mistakenly pressed
Fn + F12 which was Wifi button with 'Radio' symbol on it, which disabled my wifi connection.

Running below command in Terminal, you can see the issue:

> rfkill list all 0: Toshiba Bluetooth: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: yes <------ that's because I press Wifi button (above) mistakenly

Solution: Press again the Fn + F12 (or, some other key where you have Radio symbol)

Now run again the same command:

> rfkill list all 0: Toshiba Bluetooth: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no <------ no means solved.

Now, go to:

(Windows button, if you have on the keyboard) > Settings > Wifi > move to On > select your Wiki connection to enter credentials

Done, your internet is back on.

| improve this answer | |
1

If the bcmwl-kernel-source solution did not work for you and you want to keep secure boot enabled, then try the following:

Create a set of keys for signing:

openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=Descriptive common name/"

Import the key. You'll be prompted for a password here, which you'll need to remember. Your BIOS should prompt you for the password after the reboot.

sudo mokutil --import MOK.der

Restart:

reboot

You should have been prompted by your BIOS for the password. Assuming that worked, then you'll want to test that your MOK was successfully enrolled.

mokutil --test-key MOK.der

Now that your MOK has been enrolled. You'll need to install the drivers for you wifi.

git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
git checkout extended
sudo make install

You're drivers are available for adding to your kernel, but you need to sign them first before adding them because you have secure boot enabled. So use the keys you generated earlier to sign your drivers.

sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtlwifi)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl_pci)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n btcoexist)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl8723-common)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n phydm_mod)
sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl8723de)

Finally, add the rtl8723de drivers to the kernel in this order

sudo modprobe -r rtlwifi
sudo modprobe rtlwifi
sudo modprobe -r rtl_pci
sudo modprobe rtl_pci
sudo modprobe -r btcoexist
sudo modprobe btcoexist
sudo modprobe -r rtl8723-common
sudo modprobe rtl8723-common
sudo modprobe -r phydm_mod
sudo modprobe phydm_mod
sudo modprobe -r rtl8723de
sudo modprobe rtl8723de

On a side note: for the final step you might be able to get away with just writing:

sudo modprobe -r rtl8723de
sudo modprobe rtl8723de

modprobe knows which drivers rtl8723de depends on and should therefore be able to add everything that rtl8723de depends on along with rtl8723de. However, I didn't add my drivers this way and thus, can't guarantee this option will work.


Sources: 1, 2, 3

| improve this answer | |
0

You could try the Realtek RTL8723DE module for Linux kernel version >= 4.15.

To install it, run:

git clone https://github.com/smlinux/rtl8723de.git -b 4.15-up
dkms add ./rtl8723de
dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
depmod -a
reboot
| improve this answer | |
  • Welcome, it is a Broadcom BCM43142 not a Realtek wifi card. – GAD3R Apr 9 '19 at 15:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.