0

I'm trying to help a friend of mine that is having some big issues installing a working Linux on it's laptop (Windows works without any problem). We tried to install debian 9 (and also xUbuntu 16.04 LTS), the first time the installer froze, and the second time, everything worked fine, but then some random freeze occurs after the reboot. Sometimes the computer freeze after 10s, sometimes after 30mn... And when it occurs, sometimes the Alt+Imp+...b works, sometimes we need to do a "hard" reboot by pressing the power button several seconds, and this hard reboot always corrupt the file system.

We tried to install the proprietary drivers proposed by Ubuntu (the only available driver was about an AMD micro code), but it does not change anything. And also, most of the time the freeze corrupt the system partition, and make the system unable to boot (we just get a prompt), so it's really annoying to debug.

I managed to remotely copy the logs, but I didn't really see any error that appears when the freeze occurs... I got however a few errors during the boot the I report below:

In kern.log:

Nov  7 20:01:44 E402BA kernel: [    1.082258] ACPI Error: [^^^PB2_.VGA_.AFN7] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
Nov  7 20:01:44 E402BA kernel: [    1.082267] ACPI Error: Method parse/execution failed [\_SB.PCI0.VGA.LCDD._BCM] (Node ffff937e368b05a0), AE_NOT_FOUND (20160930/psparse-543)
Nov  7 20:01:44 E402BA kernel: [    1.082274] ACPI Error: Evaluating _BCM failed (20160930/video-343)
Nov  7 20:01:44 E402BA kernel: [    1.082359] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input6
Nov  7 20:01:44 E402BA kernel: [    1.089708] [drm] amdgpu kernel modesetting enabled.
Nov  7 20:01:44 E402BA kernel: [    1.089775] wmi: Mapper loaded
Nov  7 20:01:44 E402BA kernel: [    1.093040] AMD IOMMUv2 driver by Joerg Roedel <jroedel@suse.de>
Nov  7 20:01:44 E402BA kernel: [    1.098601] sdhci: Secure Digital Host Controller Interface driver

and

Nov  7 20:01:44 E402BA kernel: [    8.096150] input: Asus Wireless Radio Control as /devices/LNXSYSTM:00/LNXSYBUS:00/ATK4002:00/input/input14
Nov  7 20:01:44 E402BA kernel: [    8.112013] tpm_crb MSFT0101:00: can't request region for resource [mem 0xdd8b3000-0xdd8b3fff]
Nov  7 20:01:44 E402BA kernel: [    8.112026] tpm_crb: probe of MSFT0101:00 failed with error -16
Nov  7 20:01:44 E402BA kernel: [    8.156666] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Nov  7 20:01:44 E402BA kernel: [    8.229445] piix4_smbus 0000:00:14.0: SMBus Host Controller at 0xb00, revision 0

in the .journal files:

nov. 17 15:04:58 E402BA kernel: [Firmware Bug]: cpu 0, invalid threshold interrupt offset 1 for bank 4, block 0 (MSR00000413=0xd000000001000000)
nov. 17 15:04:58 E402BA kernel: PCCT header not found.
nov. 17 15:04:58 E402BA kernel: pmd_set_huge: Cannot satisfy [mem 0xf8000000-0xf8200000] with a huge-page mapping due to MTRR override.
nov. 17 15:04:58 E402BA kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored

You can find here all the hardware specification given by lshw : https://paste.ubuntu.com/26353637/ but basically the CPU is AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G, and you can notice that the drive is a SSD.

Do you know if these errors can be linked with the freeze? If not, do you know what I can try to solve the problem?

Thanks!

0

Several people have the same problem. https://askubuntu.com/questions/990466/ubuntu-16-04-3-stalls-on-amd-a9-9420-processor-radeon-r5-graphics/1004062#1004062. I think it is the compatibility between Ubuntu 16.04 and AMD A9 9420. However, Ubuntu 14.04 and 17.10 are working fine.

  • Hum, I also tried debian 9, and the same problem occurs... – tobiasBora Feb 24 '18 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.