1

I use several keyboards layouts on a regular basis. Two of which make use of dead keys for French language.

$ cat /etc/default/keyboard
XKBLAYOUT=us,fr,fr
XKBVARIANT=dvp,bepo,latin9
BACKSPACE=guess

This morning, after a sudo apt-get upgrade on Debian 9 (stretch), which may or may not be involved in the problem, dead keys stopped working as dead keys (i.e. hitting ^ then e produces ^e instead of ê), which makes typing french quite difficult.

The new behaviour is persistent after reboot and affects several applications:

  • firefox
  • thunderbird
  • gnome-terminal
  • gedit
  • nautilus

But not VLC or xterm.. what should I conclude?
How do I get my dead keys working again in all applications?

1

I had the same problem, on Debian Stretch, and I am using bépo too.

I solved it by using IBUS (yet I guess FCITX and some others can manage it too).

To me, dead keys worked fine in TTY. So I guess the problem «only» happen in software getting keyboard configuration from GUI (X?).

To install Ibus: sudo apt-get install ibus

Ibus comes with a GUI configuration tool, and bépo is available. Setting Ibus to start automatically with the session can help.

  • Well, it finally works after a reboot I think :D (unless the bug's gone alone XD) Thank you again :) – iago-lito Jan 15 '18 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.