0

Running arch linux, I have qt5-base installed, which provides libQt5Core.so.5.

Running ldconfig finds the shared object:

$ sudo ldconfig -v | grep libQt5Core
libQt5Core.so.5 -> libQt5Core.so.5.10.0

but when I run ldd on programs requiring libQt5Core.so, it is not found. Trying to start these programs fails:

$ ldd $(which keepassx) | grep libQt5Core
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found

$ ldd /usr/lib/notepadqq/notepadqq-bin | grep libQt5Core
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found
libQt5Core.so.5 => not found

/usr/lib/libQt5Core.so is a symlink to libQt5Core.so.5.10.0 which has the following file output:

/usr/lib/libQt5Core.so.5.10.0: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, BuildID[sha1]=4da280cdc46f7f0e4f257556e2ecc6b2eb31afa3, for GNU/Linux 3.17.0, stripped

The file output for keepassx is:

 $ file $(which keepassx) /usr/lib/notepadqq/notepadqq-bin: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0, BuildID[sha1]=8fafc88639032c270fd9d4c153720dc33db44823, stripped

I've tried re-installing qt5-core and doing full system upgrades, but neither help. How can I fix my system so that programs requiring libQt5Core.so can be run?

2

This turns out to be a packaging problem with qt5-base in the arch linux arm repo: https://archlinuxarm.org/forum/viewtopic.php?f=15&t=12396

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.