1

amdgpu is installed, kernel modules are loaded:

# lsmod|grep amdgpu
amdgpu               2031616  0
ttm                    98304  1 amdgpu
drm_kms_helper        163840  1 amdgpu
drm                   372736  3 amdgpu,ttm,drm_kms_helper
i2c_algo_bit           16384  1 amdgpu
mfd_core               16384  1 amdgpu

amdgpu X driver is installed:

# dpkg -l|grep amdgpu
ii  libdrm-amdgpu1:amd64                                             2.4.74-1                                    amd64        Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii  libdrm-amdgpu1:i386                                              2.4.74-1                                    i386         Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii  xserver-xorg-video-amdgpu                                        1.4.0-1                                     amd64        X.Org X server -- AMDGPU display driver

I've even tried to specify to load amdgpu driver in Xorg.conf:

# cat /etc/X11/xorg.conf
Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"

However it looks like it is not tried to load:

# grep LoadModule Xorg.0.log
[    57.973] (II) LoadModule: "glx"
[    58.107] (II) LoadModule: "ati"
[    58.154] (II) LoadModule: "radeon"
[    58.275] (II) LoadModule: "modesetting"
[    58.297] (II) LoadModule: "fbdev"
[    58.314] (II) LoadModule: "vesa"
[    58.384] (II) LoadModule: "fbdevhw"
[    58.471] (II) LoadModule: "fb"
[    58.507] (II) LoadModule: "shadow"
[    60.079] (II) LoadModule: "libinput"

lshw -c video output:

  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Richland [Radeon HD 8650G]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:b0000000-bfffffff ioport:6000(size=256) memory:d6100000-d613ffff memory:c0000-dffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Mars [Radeon HD 8670A/8670M/8750M]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller cap_list
       configuration: latency=0
       resources: memory:c0000000-cfffffff memory:d6000000-d603ffff ioport:5000(size=256) memory:d6040000-d605ffff

How can this happen? What to do to force to load amdgpu driver?

| improve this question | | | | |
  • What driver are you using? Run lshw -c video and look for the line "configuration". – ejjl Jan 7 '18 at 10:10
  • I add this info to the question. – quantummind Jan 7 '18 at 17:41
  • Still does not work. Can anyone help? – quantummind May 1 '18 at 5:26
1

adding the amdgpu.si_support=1 radeon.si_support=0 kernel parameter should work with kernel 4.13 or above.

see : Enable Southern Islands (SI) and Sea Islands (CIK) support for detail.

| improve this answer | | | | |
0

1/ This card product: Richland [Radeon HD 8650G] appears to have a TeraScale 3 architecture (see this Wiki article), and is not supported by the AMDGPU driver (it is too old). See this helpful article from the Archlinux wiki.

According to the Debian wiki you should install the xserver-xorg-video-ati driver wrapper package instead of AMDGPU.

2/ Then there is product: Mars [Radeon HD 8670A/8670M/8750M].

This card is has a 'GCN 1st gen' architecture, but it seems that it is not supported by the AMDGPU driver (again, see this helpful article from the Archlinux wiki). The ATI package should provide a driver for it.

Edit: See @susurri's answer: The GCN 1st gen card would be a Southern Island card (that is what they called the Desktop versions anyhow), and could be supported by AMDGPU, meeting certain requirements.

Note that you might have to/ want to install the firmware-amd-graphics or firmware-linux-nonfree package if you encounter and dislike poor 2D/3D support. See that same article on the Debian Wiki.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.