I'm trying to install Debian 9 on an ARCHOS 90 CESIUM tablet. The basic stuff is already working with Liquorix kernel but with the accelerator (nor the touchscreen).

For the accelerator I'm following the instructions from Change iio-sensors data via custom ACCEL_MOUNT_MATRIX, but after several tries, I'm not able to put it working properly.

$ udevadm info -n "/dev/iio:device0"
P: /devices/platform/80860F41:02/i2c-2/i2c-SMO8500:00/iio:device0
N: iio:device0
E: DEVNAME=/dev/iio:device0
E: DEVPATH=/devices/platform/80860F41:02/i2c-2/i2c-SMO8500:00/iio:device0
E: DEVTYPE=iio_device
E: IIO_SENSOR_PROXY_TYPE=iio-buffer-accel
E: MAJOR=245
E: SYSTEMD_WANTS=iio-sensor-proxy.service
E: TAGS=:systemd:

$ cat /sys/class/dmi/id/modalias 

$ journalctl -b | grep iio
Jan 06 21:30:19 tablet iio-sensor-prox[416]: Could not find trigger name associated with /sys/devices/platform/80860F41:02/i2c-2/i2c-SMO8500:00/iio:device0

So, I created a custom sensor file for udev:

$ cat /etc/udev/hwdb.d/61-sensor-local.hwdb
    ACCEL_MOUNT_MATRIX=0, 1, 0; -1, 0, 0; 0, 0, 1

Updated udev hwdb and trigger...

$ systemd-hwdb update
$ udevadm trigger

...but the custom matrix does not appear...

$ udevadm info -export-db | grep ACCEL

I tried several formats, but no one works.


Have you tried


as your udev-rule?

Did you do the hwdb-update as root / sudo?

| improve this answer | |
  • I can't at this moment, but I'll give you feedback tomorrow. Thanks. Edited: all instructions above were executed as root :) – Jesús R.A. Jan 11 '18 at 14:24
  • I tried that rule and still no luck :-\ Thanks anyway! – Jesús R.A. Jan 12 '18 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.